blob: f4b7a32cea01197fc956da720a65c3d096c53cec [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "C bindings for apps which will manipulate JSON data"
2DESCRIPTION = "JSON-C implements a reference counting object model that allows you to easily construct JSON objects in C."
3HOMEPAGE = "https://github.com/json-c/json-c/wiki"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=de54b60fbbc35123ba193fea8ee216f2"
6
Andrew Geissler220dafd2023-10-04 10:18:08 -05007SRC_URI = "https://s3.amazonaws.com/json-c_releases/releases/${BP}.tar.gz \
8 file://run-ptest \
9 "
10SRC_URI[sha256sum] = "7550914d58fb63b2c3546f3ccfbe11f1c094147bd31a69dcd23714d7956159e6"
11
12# NVD uses full tag name including date
13CVE_VERSION = "0.17-20230812"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014
Andrew Geisslereff27472021-10-29 15:35:00 -050015UPSTREAM_CHECK_URI = "https://github.com/${BPN}/${BPN}/tags"
Brad Bishop00e122a2019-10-05 11:10:57 -040016UPSTREAM_CHECK_REGEX = "json-c-(?P<pver>\d+(\.\d+)+)-\d+"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080017
Patrick Williams213cb262021-08-07 19:21:33 -050018RPROVIDES:${PN} = "libjson"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080019
Patrick Williams92b42cb2022-09-03 06:53:57 -050020inherit cmake ptest
21
22do_install_ptest() {
23 install -d ${D}/${PTEST_PATH}/tests
24 install ${B}/tests/test* ${D}/${PTEST_PATH}/tests
25 install ${S}/tests/*.test ${D}/${PTEST_PATH}/tests
26 install ${S}/tests/*.expected ${D}/${PTEST_PATH}/tests
27 install ${S}/tests/test-defs.sh ${D}/${PTEST_PATH}/tests
Andrew Geissler220dafd2023-10-04 10:18:08 -050028 install ${S}/tests/*json ${D}/${PTEST_PATH}/tests
Patrick Williams92b42cb2022-09-03 06:53:57 -050029}
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080030
31BBCLASSEXTEND = "native nativesdk"