blob: 7ca4977b97ed5a167ee739338598d1c2487e473f [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Perl-cross build system"
2HOMEPAGE = "https://github.com/arsv/perl-cross"
3DESCRIPTION = "perl-cross provides configure script, top-level Makefile and some auxiliary files for perl, \
4with the primary emphasis on cross-compiling the source."
5SECTION = "devel"
6LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
7# README.md is taken from https://github.com/arsv/perl-cross/blob/master/README.md
8# but is not provided inside the release tarballs
9LIC_FILES_CHKSUM = "file://${WORKDIR}/README.md;md5=252fcce2026b765fee1ad74d2fb07a3b"
10
Andrew Geissler87f5cff2022-09-30 13:13:31 -050011inherit allarch github-releases
Andrew Geissler9aee5002022-03-30 16:27:02 +000012
Andrew Geissler87f5cff2022-09-30 13:13:31 -050013SRC_URI = "${GITHUB_BASE_URI}/download/${PV}/perl-cross-${PV}.tar.gz;name=perl-cross \
Andrew Geissler9aee5002022-03-30 16:27:02 +000014 file://README.md \
15 file://0001-perl-cross-add-LDFLAGS-when-linking-libperl.patch \
16 file://determinism.patch \
17 file://0001-Makefile-check-the-file-if-patched-or-not.patch \
Andrew Geissler5082cc72023-09-11 08:41:39 -040018 file://0001-cnf-configure_pfmt.sh-add-32-bit-integer-format-defi.patch \
Andrew Geissler9aee5002022-03-30 16:27:02 +000019 "
Andrew Geissler87f5cff2022-09-30 13:13:31 -050020GITHUB_BASE_URI = "https://github.com/arsv/perl-cross/releases/"
Andrew Geissler9aee5002022-03-30 16:27:02 +000021
Andrew Geissler5082cc72023-09-11 08:41:39 -040022SRC_URI[perl-cross.sha256sum] = "d744a390939e2ebb9a12f6725b4d9c19255a141d90031eff90ea183fdfcbf211"
Andrew Geissler9aee5002022-03-30 16:27:02 +000023
24S = "${WORKDIR}/perl-cross-${PV}"
25
26do_configure () {
27}
28
29do_compile () {
30}
31
32do_install:class-native() {
33 mkdir -p ${D}/${datadir}/perl-cross/
34 cp -rf ${S}/* ${D}/${datadir}/perl-cross/
35 rm -rf ${D}/${datadir}/perl-cross/patches/
36}
37
38BBCLASSEXTEND = "native"
39