blob: 76e3ba5b6287d56fe281ce59cb222792f5ef51d2 [file] [log] [blame]
Jeremy Kerr882199e2016-03-17 17:35:27 +08001SUMMARY = "OpenBMC console daemon"
2DESCRIPTION = "Daemon to handle UART console connections"
3HOMEPAGE = "http://github.com/openbmc/obmc-console"
4PR = "r1"
5
6inherit obmc-phosphor-license
7inherit obmc-phosphor-systemd
8inherit autotools
Ratan Guptadf7dfd42016-10-01 14:57:15 -05009inherit obmc-phosphor-discovery-service
Jeremy Kerr882199e2016-03-17 17:35:27 +080010
11TARGET_CFLAGS += "-fpic -O2"
12
Matthew Barth3e20a722016-09-26 16:26:27 -050013DEPENDS += "autoconf-archive-native"
14
Jeremy Kerr882199e2016-03-17 17:35:27 +080015SRC_URI += "git://github.com/openbmc/obmc-console"
Brad Bishopf75c9602016-08-30 14:14:24 -040016SRC_URI += "file://${PN}.conf"
Jeremy Kerr2a9a9d72016-04-12 13:10:12 +080017
Patrick Williamsb20e8042016-10-24 01:50:02 -050018SRCREV = "cfc9a89aae080d89d3184e75d5ba6c4edd02d071"
Jeremy Kerr882199e2016-03-17 17:35:27 +080019
Ratan Guptadf7dfd42016-10-01 14:57:15 -050020REGISTERED_SERVICES_${PN} += "obmc_console:tcp:2200"
Vishwanatha Subbannae4bfd682016-10-01 11:34:42 -050021OBMC_CONSOLE_HOST_TTY ?= "ttyVUART0"
22SYSTEMD_SUBSTITUTIONS += "OBMC_CONSOLE_HOST_TTY:${OBMC_CONSOLE_HOST_TTY}:${PN}-ssh@.service"
Yi Lif1c10dd2016-10-21 12:08:47 +080023SYSTEMD_SUBSTITUTIONS += "OBMC_CONSOLE_HOST_TTY:${OBMC_CONSOLE_HOST_TTY}:${PN}-ssh.socket"
Ratan Guptadf7dfd42016-10-01 14:57:15 -050024
Brad Bishopf75c9602016-08-30 14:14:24 -040025SYSTEMD_SERVICE_${PN} = " \
Vishwanatha Subbannae4bfd682016-10-01 11:34:42 -050026 ${PN}@.service \
27 ${PN}@${OBMC_CONSOLE_HOST_TTY}.service \
Brad Bishopf75c9602016-08-30 14:14:24 -040028 ${PN}-ssh.socket \
29 ${PN}-ssh@.service \
30 "
Jeremy Kerr882199e2016-03-17 17:35:27 +080031do_install_append() {
32 install -m 0755 -d ${D}${sysconfdir}
33 install -m 0644 ${WORKDIR}/${PN}.conf ${D}${sysconfdir}/${PN}.conf
Jeremy Kerr882199e2016-03-17 17:35:27 +080034}
35
36S = "${WORKDIR}/git"