blob: 55ad78c091c0e962dffdce3d25b9802ad467752c [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "OpenGL driver testing framework"
2LICENSE = "MIT & LGPLv2+ & GPLv3 & GPLv2+ & BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0"
4
5SRC_URI = "git://anongit.freedesktop.org/piglit \
6 file://0001-tests-Fix-missing-include-of-Xutil.h.patch"
7
8# From 2014/12/04
9SRCREV = "126c7d049b8f32e541625d5a35fbc5f5e4e7fbf8"
10# (when PV goes above 1.0 remove the trailing r)
11PV = "1.0+gitr${SRCPV}"
12
13S = "${WORKDIR}/git"
14
15DEPENDS = "virtual/libx11 libxrender waffle virtual/libgl libglu python-mako-native python-numpy-native"
16
17inherit cmake pythonnative distro_features_check
18# depends on virtual/libx11
19REQUIRED_DISTRO_FEATURES = "x11"
20
Patrick Williamsf1e5d692016-03-30 15:21:19 -050021# The built scripts go into the temporary directory according to tempfile
22# (typically /tmp) which can race if multiple builds happen on the same machine,
23# so tell it to use a directory in ${B} to avoid overwriting.
24export TEMP = "${B}/temp/"
25do_compile[dirs] =+ "${B}/temp/"
26
Patrick Williamsc124f4f2015-09-15 14:41:29 -050027PACKAGECONFIG ??= ""
28PACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut,"
29
30do_configure_prepend() {
31 if [ "${@bb.utils.contains('PACKAGECONFIG', 'freeglut', 'yes', 'no', d)}" = "no" ]; then
32 sed -i -e "/^#.*include <GL\/freeglut_ext.h>$/d" ${S}/src/piglit/glut_wrap.h
33 sed -i -e "/^#.*include.*<GL\/glut.h>$/d" ${S}/src/piglit/glut_wrap.h
34 fi
35}
36
37FILES_${PN}-dbg += "${libdir}/piglit/*/.debug/"
38
39RDEPENDS_${PN} = "waffle python python-mako python-json python-subprocess \
40 python-argparse python-importlib python-unixadmin \
41 python-multiprocessing python-textutils python-netserver python-shell \
42 mesa-demos bash \
43 "
44
45INSANE_SKIP_${PN} += "dev-so"