Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Set of i2c tools for linux" |
| 2 | HOMEPAGE = "https://i2c.wiki.kernel.org/index.php/I2C_Tools" |
| 3 | SECTION = "base" |
| 4 | LICENSE = "GPLv2+" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
| 6 | |
| 7 | SRC_URI = "${KERNELORG_MIRROR}/software/utils/i2c-tools/${BP}.tar.gz \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 8 | " |
| 9 | |
Brad Bishop | 977dc1a | 2019-02-06 16:01:43 -0500 | [diff] [blame] | 10 | SRC_URI[md5sum] = "3536237a6b51fb10caacdc3b8a496237" |
| 11 | SRC_URI[sha256sum] = "ef8f77afc70e7dbfd1171bfeae87a8a7f10074829370ce8d9ccd585a014e0073" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 12 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 13 | inherit update-alternatives |
| 14 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 15 | EXTRA_OEMAKE = "bindir=${bindir} sbindir=${sbindir} \ |
| 16 | incdir=${includedir} libdir=${libdir} \ |
| 17 | mandir=${mandir} \ |
| 18 | EXTRA=eeprog" |
| 19 | |
| 20 | do_install() { |
| 21 | oe_runmake 'DESTDIR=${D}' install |
| 22 | } |
| 23 | |
| 24 | PACKAGES =+ "${PN}-misc" |
| 25 | FILES_${PN}-misc = "${sbindir}/i2c-stub-from-dump \ |
| 26 | ${bindir}/ddcmon \ |
| 27 | ${bindir}/decode-edid \ |
| 28 | ${bindir}/decode-dimms \ |
| 29 | ${bindir}/decode-vaio \ |
| 30 | " |
| 31 | RDEPENDS_${PN}-misc = "${PN} perl perl-module-posix \ |
| 32 | perl-module-constant perl-module-file-basename \ |
| 33 | perl-module-fcntl perl-module-strict perl-module-vars \ |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame] | 34 | perl-module-carp \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 35 | " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 36 | |
| 37 | ALTERNATIVE_PRIORITY = "100" |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 38 | ALTERNATIVE_${PN} = "i2cdetect i2cdump i2cget i2cset i2ctransfer" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 39 | ALTERNATIVE_LINK_NAME[i2cdetect] = "${sbindir}/i2cdetect" |
| 40 | ALTERNATIVE_LINK_NAME[i2cdump] = "${sbindir}/i2cdump" |
| 41 | ALTERNATIVE_LINK_NAME[i2cget] = "${sbindir}/i2cget" |
| 42 | ALTERNATIVE_LINK_NAME[i2cset] = "${sbindir}/i2cset" |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 43 | ALTERNATIVE_LINK_NAME[i2ctransfer] = "${sbindir}/i2ctransfer" |