blob: fdd7d8e60f9fdceede9294904c6e0ab0841d146c [file] [log] [blame]
Brad Bishop21f39fd2017-01-17 09:14:15 -05001SUMMARY = "Phosphor IPMI Inventory Plugin"
2DESCRIPTION = "A Phosphor IPMI plugin that updates inventory."
Brad Bishopcbac7fc2016-06-13 12:53:41 -04003DEPENDS += " \
Brad Bishop2f63e8c2017-01-28 13:00:52 -05004 virtual/phosphor-ipmi-fru-inventory \
Deepak Kodihalli48be0fd2017-02-20 04:55:20 -06005 virtual/phosphor-ipmi-fru-properties \
Deepak Kodihallic11cbc52017-02-16 07:50:37 -06006 sdbusplus \
Andrew Geissler35c7c072020-04-04 07:31:23 +00007 ${PYTHON_PN}-mako-native \
8 ${PYTHON_PN}-pyyaml-native \
Brad Bishopceb1c9a2017-01-17 10:07:14 -05009 phosphor-ipmi-host \
Patrick Venture5508db22018-10-16 19:50:55 -070010 phosphor-logging \
Patrick Venturee4ccd822019-03-26 11:07:32 -070011 cli11 \
Brad Bishopcbac7fc2016-06-13 12:53:41 -040012 "
Ed Tanous9936f862022-09-19 09:13:20 -070013PV = "1.0+git${SRCPV}"
14PR = "r1"
William A. Kennington III147a7952020-03-30 12:03:28 -070015
16SRC_URI += "file://of-name-to-eeprom.sh"
17
Patrick Williams12fc9392021-08-06 09:16:53 -050018SYSTEMD_SERVICE:${PN} += "obmc-read-eeprom@.service"
Chris Austen764ae432015-11-01 22:27:34 -060019S = "${WORKDIR}/git"
20
Andrew Geissler65f13882023-07-19 13:21:47 -050021inherit meson pkgconfig
Ed Tanous9936f862022-09-19 09:13:20 -070022inherit obmc-phosphor-systemd
23inherit obmc-phosphor-ipmiprovider-symlink
24inherit phosphor-ipmi-fru
25inherit python3native
Brad Bishop2f63e8c2017-01-28 13:00:52 -050026
Andrew Geissler65f13882023-07-19 13:21:47 -050027IPMI_FRU_YAML ?= "${STAGING_DIR_NATIVE}${config_datadir}/config.yaml"
28IPMI_FRU_PROP_YAML ?= "${STAGING_DIR_NATIVE}${properties_datadir}/extra-properties.yaml"
29
30
31EXTRA_OEMESON = " \
32 -Dfru_yaml=${IPMI_FRU_YAML} \
33 -Dproperties_yaml=${IPMI_FRU_PROP_YAML} \
34 "
William A. Kennington III147a7952020-03-30 12:03:28 -070035
Patrick Williams12fc9392021-08-06 09:16:53 -050036do_install:append() {
William A. Kennington III147a7952020-03-30 12:03:28 -070037 install -d ${D}${bindir}
38 install -m 0755 ${WORKDIR}/of-name-to-eeprom.sh ${D}${bindir}
39}
Ed Tanous9936f862022-09-19 09:13:20 -070040
41RDEPENDS:${PN} += "bash"
42
43FILES:${PN} += "${bindir}/of-name-to-eeprom.sh"
44FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
45FILES:${PN}:append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
46FILES:${PN}-dev:append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
47
48require ${BPN}.inc
49
50HOSTIPMI_PROVIDER_LIBRARY += "libstrgfnhandler.so"