Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | # SPDX-License-Identifier: MIT |
| 2 | # Copyright (C) 2021 iris-GmbH infrared & intelligent sensors |
| 3 | |
| 4 | SUMMARY = "Tool for managing many Git repositories" |
| 5 | DESCRIPTION = "Repo is a tool built on top of Git. Repo helps manage many Git repositories, does the uploads to revision control systems, and automates parts of the development workflow." |
| 6 | HOMEPAGE = "https://android.googlesource.com/tools/repo" |
| 7 | SECTION = "console/utils" |
| 8 | |
| 9 | LICENSE = "Apache-2.0" |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| 11 | |
| 12 | SRC_URI = "git://gerrit.googlesource.com/git-repo.git;protocol=https;branch=main \ |
| 13 | file://0001-python3-shebang.patch \ |
| 14 | " |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 15 | SRCREV = "d56e2eb4216827284220fcc35af42e60b4faaea6" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 16 | |
| 17 | MIRRORS += "git://gerrit.googlesource.com/git-repo.git git://github.com/GerritCodeReview/git-repo.git" |
| 18 | |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
| 21 | do_configure:prepend() { |
| 22 | sed -Ei "s/REPO_REV\s*=\s*('|\")stable('|\")/REPO_REV = '${SRCREV}'/g" ${S}/repo |
| 23 | } |
| 24 | |
| 25 | do_install() { |
| 26 | install -D ${WORKDIR}/git/repo ${D}${bindir}/repo |
| 27 | } |
| 28 | |
| 29 | RDEPENDS:${PN} = "python3 git" |
| 30 | |
| 31 | BBCLASSEXTEND = "native nativesdk" |