blob: 5887a3d9d852471f6a8852ba34b7502fc7e8bdd3 [file] [log] [blame]
Patrick Williams6f746642021-08-06 07:40:55 -05001FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
Kumar Thangavel06911e32021-02-17 12:30:20 +05302
Kumar Thangavel03fcd262022-06-10 16:11:27 +05303SRC_URI:append:fb-compute-singlehost = " file://ttyS2.conf"
Kumar Thangavel06911e32021-02-17 12:30:20 +05304
Kumar Thangavel03fcd262022-06-10 16:11:27 +05305SRC_URI:append:fb-compute-multihost = " file://ttyS0.conf \
6 file://ttyS1.conf \
7 file://ttyS2.conf \
8 file://ttyS3.conf "
9
Kumar Thangavel06911e32021-02-17 12:30:20 +053010
Patrick Williams6f746642021-08-06 07:40:55 -050011do_install:append() {
Kumar Thangavel06911e32021-02-17 12:30:20 +053012
13 # Install the configurations
14 install -m 0755 -d ${D}${sysconfdir}/${BPN}
15 install -m 0644 ${WORKDIR}/*.conf ${D}${sysconfdir}/${BPN}/
16
17 # Remove upstream-provided default configuration
18 rm -f ${D}${sysconfdir}/${BPN}/ttyVUART0.conf
19}