Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | BPN = "qemu" |
| 2 | |
| 3 | require qemu-native.inc |
| 4 | |
Brad Bishop | c68388fc | 2019-08-26 01:33:31 -0400 | [diff] [blame] | 5 | # As some of the files installed by qemu-native and qemu-system-native |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 6 | # are the same, we depend on qemu-native to get the full installation set |
| 7 | # and avoid file clashes |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 8 | DEPENDS = "glib-2.0-native zlib-native pixman-native qemu-native bison-native" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 9 | |
| 10 | EXTRA_OECONF_append = " --target-list=${@get_qemu_system_target_list(d)}" |
| 11 | |
| 12 | PACKAGECONFIG ??= "fdt alsa kvm" |
| 13 | |
| 14 | # Handle distros such as CentOS 5 32-bit that do not have kvm support |
| 15 | PACKAGECONFIG_remove = "${@'kvm' if not os.path.exists('/usr/include/linux/kvm.h') else ''}" |
| 16 | |
| 17 | do_install_append() { |
| 18 | install -Dm 0755 ${WORKDIR}/powerpc_rom.bin ${D}${datadir}/qemu |
| 19 | |
| 20 | # The following is also installed by qemu-native |
| 21 | rm -f ${D}${datadir}/qemu/trace-events-all |
| 22 | rm -rf ${D}${datadir}/qemu/keymaps |
| 23 | rm -rf ${D}${datadir}/icons/ |
| 24 | } |