blob: 2cd99706b4339a1805ce4484280a40192f8b0257 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Checksumming Copy on Write Filesystem utilities"
2DESCRIPTION = "Btrfs is a new copy on write filesystem for Linux aimed at \
3implementing advanced features while focusing on fault tolerance, repair and \
4easy administration. \
5This package contains utilities (mkfs, fsck, btrfsctl) used to work with \
6btrfs and an utility (btrfs-convert) to make a btrfs filesystem from an ext3."
7
8HOMEPAGE = "https://btrfs.wiki.kernel.org"
9
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067"
12SECTION = "base"
13DEPENDS = "util-linux attr e2fsprogs lzo acl python3-setuptools-native"
14DEPENDS_append_class-target = " udev"
15RDEPENDS_${PN} = "libgcc"
16
Brad Bishopf3fd2882019-06-21 08:06:37 -040017SRCREV = "781e36a784faa58a4f0515eef124af860d59e2c0"
Brad Bishopc342db32019-05-15 21:57:59 -040018SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git \
Brad Bishopc342db32019-05-15 21:57:59 -040019 file://0001-Add-a-possibility-to-specify-where-python-modules-ar.patch \
20 "
21
22inherit autotools-brokensep pkgconfig manpages distutils3-base
23
24CLEANBROKEN = "1"
25
26PACKAGECONFIG[manpages] = "--enable-documentation, --disable-documentation, asciidoc-native xmlto-native"
27EXTRA_OECONF = " --disable-zstd"
28EXTRA_OECONF_append_libc-musl = " --disable-backtrace "
Brad Bishop15ae2502019-06-18 21:44:24 -040029EXTRA_PYTHON_CFLAGS = "${DEBUG_PREFIX_MAP}"
30EXTRA_PYTHON_CFLAGS_class-native = ""
31EXTRA_PYTHON_LDFLAGS = "${LDFLAGS}"
32EXTRA_OEMAKE = "V=1 'EXTRA_PYTHON_CFLAGS=${EXTRA_PYTHON_CFLAGS}' 'EXTRA_PYTHON_LDFLAGS=${EXTRA_PYTHON_LDFLAGS}'"
Brad Bishopc342db32019-05-15 21:57:59 -040033
34do_configure_prepend() {
35 # Upstream doesn't ship this and autoreconf won't install it as automake isn't used.
36 mkdir -p ${S}/config
37 cp -f $(automake --print-libdir)/install-sh ${S}/config/
38}
39
40S = "${WORKDIR}/git"
41
42do_install_append() {
43 oe_runmake 'DESTDIR=${D}' 'PYTHON_SITEPACKAGES_DIR=${PYTHON_SITEPACKAGES_DIR}' install_python
44}
45
46BBCLASSEXTEND = "native"