blob: 21a815345a981f1cb8120654a96a3641ff09b633 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Disk partition editing/resizing utility"
2HOMEPAGE = "http://www.gnu.org/software/parted/parted.html"
3LICENSE = "GPLv3+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=2f31b266d3440dd7ee50f92cf67d8e6c"
5SECTION = "console/tools"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05006DEPENDS = "ncurses readline util-linux virtual/libiconv"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05007PR = "r1"
8
9SRC_URI = "${GNU_MIRROR}/parted/parted-${PV}.tar.xz \
10 file://no_check.patch \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050011 file://fix-doc-mandir.patch \
12 file://fix-compile-failure-while-dis.patch \
13 file://0001-Include-fcntl.h-in-platform_defs.h.patch \
14 file://0001-Unset-need_charset_alias-when-building-for-musl.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050015 file://0002-libparted_fs_resize-link-against-libuuid-explicitly-.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050016 file://0001-Move-python-helper-scripts-used-only-in-tests-to-Pyt.patch \
Brad Bishop15ae2502019-06-18 21:44:24 -040017 file://0001-linux-Include-sys-sysmacros.h-for-major-macro.patch \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050018 file://run-ptest \
19 file://Makefile \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050020 file://0001-libparted-Use-read-only-when-probing-devices-on-linu.patch \
Brad Bishopf3fd2882019-06-21 08:06:37 -040021 file://dm_check.patch \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050022"
23
24SRC_URI[md5sum] = "0247b6a7b314f8edeb618159fa95f9cb"
25SRC_URI[sha256sum] = "858b589c22297cacdf437f3baff6f04b333087521ab274f7ab677cb8c6bb78e4"
26
27EXTRA_OECONF = "--disable-device-mapper"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050028
29inherit autotools pkgconfig gettext texinfo ptest
30
31BBCLASSEXTEND = "native"
32
33do_compile_ptest() {
34 oe_runmake -C tests print-align print-max dup-clobber duplicate fs-resize
35}
36
37do_install_ptest() {
38 t=${D}${PTEST_PATH}
39 mkdir $t/build-aux
40 cp ${S}/build-aux/test-driver $t/build-aux/
41 cp -r ${S}/tests $t
42 cp ${WORKDIR}/Makefile $t/tests/
43 sed -i "s|^VERSION.*|VERSION = ${PV}|g" $t/tests/Makefile
44 for i in print-align print-max dup-clobber duplicate fs-resize; \
45 do cp ${B}/tests/.libs/$i $t/tests/; \
46 done
47 sed -e 's| ../parted||' -i $t/tests/*.sh
48}
49
Brad Bishop393846f2019-05-20 12:24:11 -040050RDEPENDS_${PN}-ptest = "bash coreutils perl util-linux-losetup python3 make"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080051
52inherit update-alternatives
53
54ALTERNATIVE_PRIORITY = "100"
55ALTERNATIVE_${PN} = "partprobe"
56ALTERNATIVE_LINK_NAME[partprobe] = "${sbindir}/partprobe"