blob: a8eebb223bae1fa648ca120b55abbfcc8d9373a5 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Linux Trace Toolkit Userspace Tracer 2.x"
2DESCRIPTION = "The LTTng UST 2.x package contains the userspace tracer library to trace userspace codes."
3HOMEPAGE = "http://lttng.org/ust"
4BUGTRACKER = "https://bugs.lttng.org/projects/lttng-ust"
5
6LICENSE = "LGPLv2.1+ & MIT & GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=c963eb366b781252b0bf0fdf1624d9e9 \
8 file://snprintf/snprintf.c;endline=32;md5=d3d544959d8a3782b2e07451be0a903c \
9 file://snprintf/various.h;endline=31;md5=89f2509b6b4682c4fc95255eec4abe44"
10
Brad Bishop19323692019-04-05 15:28:33 -040011PYTHON_OPTION = "am_cv_python_pyexecdir='${PYTHON_SITEPACKAGES_DIR}' \
12 am_cv_python_pythondir='${PYTHON_SITEPACKAGES_DIR}' \
13 PYTHON_INCLUDE='-I${STAGING_INCDIR}/python${PYTHON_BASEVERSION}${PYTHON_ABI}' \
14"
15
16inherit autotools lib_package manpages python3native
Brad Bishopd7bf8c12018-02-25 22:55:05 -050017
18DEPENDS = "liburcu util-linux"
19RDEPENDS_${PN}-bin = "python3-core"
20
21# For backwards compatibility after rename
22RPROVIDES_${PN} = "lttng2-ust"
23RREPLACES_${PN} = "lttng2-ust"
24RCONFLICTS_${PN} = "lttng2-ust"
25
26PE = "2"
27
28SRC_URI = "https://lttng.org/files/lttng-ust/lttng-ust-${PV}.tar.bz2 \
29 file://lttng-ust-doc-examples-disable.patch \
30 "
Brad Bishop19323692019-04-05 15:28:33 -040031
Brad Bishopf3fd2882019-06-21 08:06:37 -040032SRC_URI[md5sum] = "19916ff0dec23c90f985586a8cbd1fd2"
33SRC_URI[sha256sum] = "75d5b4bb205c444a343e1297e14cd3a2503fc645a26710531cbd319c72c1a967"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050034
35CVE_PRODUCT = "ust"
36
37PACKAGECONFIG[manpages] = "--enable-man-pages, --disable-man-pages, asciidoc-native xmlto-native libxslt-native"
Brad Bishop19323692019-04-05 15:28:33 -040038PACKAGECONFIG[python3-agent] = "--enable-python-agent ${PYTHON_OPTION}, --disable-python-agent, python3, python3"
39
40FILES_${PN} += " ${PYTHON_SITEPACKAGES_DIR}/*"
41FILES_${PN}-staticdev += " ${PYTHON_SITEPACKAGES_DIR}/*.a"
42FILES_${PN}-dev += " ${PYTHON_SITEPACKAGES_DIR}/*.la"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050043
44do_install_append() {
45 # Patch python tools to use Python 3; they should be source compatible, but
46 # still refer to Python 2 in the shebang
47 sed -i -e '1s,#!.*python.*,#!${bindir}/python3,' ${D}${bindir}/lttng-gen-tp
48}