blob: 81ceb1cd91f7be63aaa2ff89b5298fa7c22f2c13 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "An asynchronous event notification library"
2HOMEPAGE = "http://libevent.org/"
3BUGTRACKER = "https://github.com/libevent/libevent/issues"
4SECTION = "libs"
5
6LICENSE = "BSD & MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=17f20574c0b154d12236d5fbe964f549"
8
9SRC_URI = " \
10 https://github.com/libevent/libevent/releases/download/release-${PV}-stable/${BP}-stable.tar.gz \
11 file://Makefile-missing-test-dir.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050012 file://run-ptest \
13"
14
Brad Bishopf3fd2882019-06-21 08:06:37 -040015SRC_URI[md5sum] = "999caf86f52943af2363bc8077f00167"
16SRC_URI[sha256sum] = "e864af41a336bb11dab1a23f32993afe963c1f69618bd9292b89ecf6904845b0"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050017
18UPSTREAM_CHECK_URI = "http://libevent.org/"
19
20S = "${WORKDIR}/${BPN}-${PV}-stable"
21
22PACKAGECONFIG ??= ""
23PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl"
24
25inherit autotools
26
27# Needed for Debian packaging
28LEAD_SONAME = "libevent-2.1.so"
29
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080030inherit ptest multilib_header
Brad Bishopd7bf8c12018-02-25 22:55:05 -050031
32DEPENDS = "zlib"
33
34BBCLASSEXTEND = "native nativesdk"
35
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080036do_install_append() {
37 oe_multilib_header event2/event-config.h
38}
39
Brad Bishopd7bf8c12018-02-25 22:55:05 -050040do_install_ptest() {
41 install -d ${D}${PTEST_PATH}/test
42 for file in ${B}/test/.libs/regress ${B}/test/.libs/test*
43 do
44 install -m 0755 $file ${D}${PTEST_PATH}/test
45 done
46}