blob: 792a1143b2987dfea4e9946c1483974acc0b8fa7 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "A portable foreign function interface library"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05002HOMEPAGE = "http://sourceware.org/libffi/"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05003DESCRIPTION = "The `libffi' library provides a portable, high level programming interface to various calling \
4conventions. This allows a programmer to call any function specified by a call interface description at run \
5time. FFI stands for Foreign Function Interface. A foreign function interface is the popular name for the \
6interface that allows code written in one language to call code written in another language. The `libffi' \
7library really only provides the lowest, machine dependent layer of a fully featured foreign function interface. \
8A layer must exist above `libffi' that handles type conversions for values passed between the two languages."
9
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=3610bb17683a0089ed64055416b2ae1b"
12
13SRC_URI = "ftp://sourceware.org/pub/libffi/${BP}.tar.gz \
14 file://not-win32.patch \
Brad Bishopf3fd2882019-06-21 08:06:37 -040015 file://0001-mips-Use-compiler-internal-define-for-linux.patch \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060016 file://0001-mips-fix-MIPS-softfloat-build-issue.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050017 file://0001-libffi-Support-musl-x32-build.patch \
Brad Bishopf3fd2882019-06-21 08:06:37 -040018 file://0001-New-RISC-V-port-281.patch \
19 "
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050020
21SRC_URI[md5sum] = "83b89587607e3eb65c70d361f13bab43"
22SRC_URI[sha256sum] = "d06ebb8e1d9a22d19e38d63fdb83954253f39bedc5d46232a05645685722ca37"
23
24EXTRA_OECONF += "--disable-builddir"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050025EXTRA_OEMAKE_class-target = "LIBTOOLFLAGS='--tag=CC'"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050026inherit autotools texinfo
27
28FILES_${PN}-dev += "${libdir}/libffi-${PV}"
29
Patrick Williamsc0f7c042017-02-23 20:41:17 -060030# Doesn't compile in MIPS16e mode due to use of hand-written
31# assembly
32MIPS_INSTRUCTION_SET = "mips"
33
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050034BBCLASSEXTEND = "native nativesdk"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050035