blob: 6320a821dcd9f89b0e25c32d3e39c23e16148c3d [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "GNOME XSLT library"
2HOMEPAGE = "http://xmlsoft.org/XSLT/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://Copyright;md5=0cd9a07afbeb24026c9b03aecfeba458"
7
8SECTION = "libs"
9DEPENDS = "libxml2"
10
Brad Bishopf3fd2882019-06-21 08:06:37 -040011SRC_URI = "http://xmlsoft.org/sources/libxslt-${PV}.tar.gz \
12 file://0001-Fix-security-framework-bypass.patch \
13"
Brad Bishop19323692019-04-05 15:28:33 -040014
15SRC_URI[md5sum] = "b3bd254a03e46d58f8ad1e4559cd2c2f"
16SRC_URI[sha256sum] = "8e36605144409df979cab43d835002f63988f3dc94d5d3537c12796db90e38c8"
17
18UPSTREAM_CHECK_REGEX = "libxslt-(?P<pver>\d+(\.\d+)+)\.tar"
19
20S = "${WORKDIR}/libxslt-${PV}"
21
22BINCONFIG = "${bindir}/xslt-config"
23
24inherit autotools pkgconfig binconfig-disabled lib_package
25
Brad Bishop19323692019-04-05 15:28:33 -040026do_configure_prepend () {
Brad Bishop15ae2502019-06-18 21:44:24 -040027 # We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header.
28 # This can be removed when upgrading to 1.1.34.
Brad Bishop19323692019-04-05 15:28:33 -040029 sed -i -e 's/ansidecl.h//' ${S}/configure.ac
30
31 # The timestamps in the 1.1.28 tarball are messed up causing this file to
32 # appear out of date. Touch it so that we don't try to regenerate it.
33 touch ${S}/doc/xsltproc.1
34}
35
36EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto --with-html-subdir=${BPN}"
37# older versions of this recipe had ${PN}-utils
38RPROVIDES_${PN}-bin += "${PN}-utils"
39RCONFLICTS_${PN}-bin += "${PN}-utils"
40RREPLACES_${PN}-bin += "${PN}-utils"
41
42# This is only needed until libxml can load the relocated catalog itself
43do_install_append_class-native () {
44 create_wrapper ${D}/${bindir}/xsltproc XML_CATALOG_FILES=${sysconfdir}/xml/catalog
45}
46
47FILES_${PN} += "${libdir}/libxslt-plugins"
48FILES_${PN}-dev += "${libdir}/xsltConf.sh"
49
50BBCLASSEXTEND = "native nativesdk"