blob: 4162b2b58f9d8fb1110e2dfb62965825ef111716 [file] [log] [blame]
James Feist9ed709c2018-10-02 16:45:42 -07001SUMMARY = "Entity Manager"
2DESCRIPTION = "Entity Manager provides d-bus configuration data \
3and configures system sensors"
4
Brad Bishopf55c8752020-08-18 19:06:53 -04005SRC_URI = "git://github.com/openbmc/entity-manager.git file://blocklist.json"
Andrew Geissler0bb229a2020-09-09 18:01:07 +00006SRCREV = "1034e026001ceafb64d828622557af25e0fa5a38"
James Feist9ed709c2018-10-02 16:45:42 -07007PV = "0.1+git${SRCPV}"
8
9LICENSE = "Apache-2.0"
10LIC_FILES_CHKSUM = "file://LICENCE;md5=a6a4edad4aed50f39a66d098d74b265b"
11
12SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.EntityManager.service \
Brad Bishop6d17b7b2020-03-18 16:33:02 -040013 ${@bb.utils.contains('DISTRO_FEATURES', 'ipmi-fru', 'xyz.openbmc_project.FruDevice.service', '', d)}"
Brad Bishopf55c8752020-08-18 19:06:53 -040014SYSTEMD_AUTO_ENABLE_${PN}_ibm-power-cpu = "disable"
James Feist9ed709c2018-10-02 16:45:42 -070015
James Feist9ed709c2018-10-02 16:45:42 -070016DEPENDS = "boost \
James Feist9ed709c2018-10-02 16:45:42 -070017 nlohmann-json \
18 sdbusplus \
19 valijson"
20
21S = "${WORKDIR}/git/"
Brad Bishop76356112020-02-14 14:07:11 -050022inherit meson systemd
Brad Bishop6d17b7b2020-03-18 16:33:02 -040023
Brad Bishopc83dff02020-03-30 14:16:34 -040024EXTRA_OEMESON = "-Dtests=disabled"
25
Brad Bishop6d17b7b2020-03-18 16:33:02 -040026PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipmi-fru', d)}"
27PACKAGECONFIG[ipmi-fru] = "-Dfru-device=true, -Dfru-device=false, i2c-tools,"
Brad Bishopf55c8752020-08-18 19:06:53 -040028
29do_install_append() {
30 install -D ${WORKDIR}/blocklist.json ${D}${datadir}/${BPN}/blacklist.json
31}