blob: 0bcc66a58f9da668088f90731c60079948f2e716 [file] [log] [blame]
Patrick Venture9afb6712018-09-17 17:14:46 -07001SUMMARY = "Google Sys OEM commands"
Patrick Ventureedb61922018-09-21 14:57:58 -07002DESCRIPTION = "Google Sys OEM commands"
Patrick Venture3adb97a2018-09-26 08:42:56 -07003HOMEPAGE = "https://github.com/openbmc/google-ipmi-sys"
4PR = "r1"
5PV = "0.1+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
Patrick Venture9afb6712018-09-17 17:14:46 -07008
9inherit autotools pkgconfig
Patrick Venture9afb6712018-09-17 17:14:46 -070010inherit systemd
11inherit obmc-phosphor-ipmiprovider-symlink
12
13DEPENDS += "autoconf-archive-native"
14DEPENDS += "sdbusplus"
15DEPENDS += "phosphor-logging"
Patrick Venture9afb6712018-09-17 17:14:46 -070016DEPENDS += "phosphor-ipmi-host"
Patrick Venture9668c752019-02-06 09:50:22 -080017DEPENDS += "nlohmann-json"
Patrick Venture9afb6712018-09-17 17:14:46 -070018
Patrick Venture9afb6712018-09-17 17:14:46 -070019S = "${WORKDIR}/git"
20SRC_URI = "git://github.com/openbmc/google-ipmi-sys"
Andrew Geissler96ccf312021-03-05 19:10:13 +000021SRCREV = "3b1b427c1fa4bcddcab1fc003410e5fa5d7a8334"
Patrick Venture9afb6712018-09-17 17:14:46 -070022
23FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
24FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
25FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
26FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
27
28HOSTIPMI_PROVIDER_LIBRARY += "libsyscmds.so"
29
30SYSTEMD_PACKAGES = "${PN}"
31SYSTEMD_SERVICE_${PN} = "gbmc-psu-hardreset.target"
32
William A. Kennington IIIa4cdbe62021-06-04 18:13:35 -070033EXTRA_OECONF += "--disable-tests"
34
William A. Kennington III577d20f2021-02-17 14:33:38 -080035CXXFLAGS_append_gbmc = '${@"" if not d.getVar("GBMC_NCSI_IF_NAME") else \
36 " -DNCSI_IPMI_CHANNEL=1 -DNCSI_IF_NAME=" + d.getVar("GBMC_NCSI_IF_NAME")}'
37
Patrick Venture9afb6712018-09-17 17:14:46 -070038do_install_append() {
39 install -d ${D}${systemd_system_unitdir}
40 install -m 0644 ${S}/gbmc-psu-hardreset.target ${D}${systemd_system_unitdir}
41}