blob: fc7a2d61abd8014f6a6e75af9a8f752c52085c17 [file] [log] [blame]
Brad Bishop15ae2502019-06-18 21:44:24 -04001DESCRIPTION = "IMA/EVM control utility"
2LICENSE = "GPL-2.0-with-OpenSSL-exception"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4
5DEPENDS += "openssl attr keyutils"
6
Patrick Williams213cb262021-08-07 19:21:33 -05007DEPENDS:class-native += "openssl-native keyutils-native"
Brad Bishop15ae2502019-06-18 21:44:24 -04008
Brad Bishop26bdd442019-08-16 17:08:17 -04009PV = "1.2.1+git${SRCPV}"
10SRCREV = "3eab1f93b634249c1720f65fcb495b1996f0256e"
11SRC_URI = "git://git.code.sf.net/p/linux-ima/ima-evm-utils;branch=ima-evm-utils-1.2.y"
Brad Bishop15ae2502019-06-18 21:44:24 -040012
13# Documentation depends on asciidoc, which we do not have, so
14# do not build documentation.
15SRC_URI += "file://disable-doc-creation.patch"
16
17# Workaround for upstream incompatibility with older Linux distros.
18# Relevant for us when compiling ima-evm-utils-native.
19SRC_URI += "file://evmctl.c-do-not-depend-on-xattr.h-with-IMA-defines.patch"
20
21# Required for xargs with more than one path as argument (better for performance).
22SRC_URI += "file://command-line-apply-operation-to-all-paths.patch"
23
Brad Bishop15ae2502019-06-18 21:44:24 -040024S = "${WORKDIR}/git"
25
Brad Bishopa48c0142020-01-06 09:48:41 -050026inherit pkgconfig autotools features_check
27
28REQUIRED_DISTRO_FEATURES = "ima"
Patrick Williams213cb262021-08-07 19:21:33 -050029REQUIRED_DISTRO_FEATURES:class-native = ""
Brad Bishop15ae2502019-06-18 21:44:24 -040030
Patrick Williams213cb262021-08-07 19:21:33 -050031EXTRA_OECONF:append:class-target = " --with-kernel-headers=${STAGING_KERNEL_BUILDDIR}"
Brad Bishop15ae2502019-06-18 21:44:24 -040032
33# blkid is called by evmctl when creating evm checksums.
34# This is less useful when signing files on the build host,
35# so disable it when compiling on the host.
Patrick Williams213cb262021-08-07 19:21:33 -050036RDEPENDS:${PN}:append:class-target = " util-linux-blkid libcrypto attr libattr keyutils"
Brad Bishop15ae2502019-06-18 21:44:24 -040037
38BBCLASSEXTEND = "native nativesdk"