blob: 74532caec3709def3a7a6bcb44d30cf2f16b5e4a [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "GNU Project parser generator (yacc replacement)"
2DESCRIPTION = "Bison is a general-purpose parser generator that converts an annotated context-free grammar into \
3an LALR(1) or GLR parser for that grammar. Bison is upward compatible with Yacc: all properly-written Yacc \
4grammars ought to work with Bison with no change. Anyone familiar with Yacc should be able to use Bison with \
5little trouble."
6HOMEPAGE = "http://www.gnu.org/software/bison/"
7LICENSE = "GPLv3"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
9SECTION = "devel"
10DEPENDS = "bison-native flex-native"
11
12SRC_URI = "${GNU_MIRROR}/bison/bison-${PV}.tar.xz \
Andrew Geissler82c905d2020-04-13 13:39:40 -050013 file://add-with-bisonlocaledir.patch \
Andrew Geissler4ed12e12020-06-05 18:00:41 -050014 "
Andrew Geissler6ce62a22020-11-30 19:58:47 -060015SRC_URI[sha256sum] = "88d9e36856b004c0887a12ba00ea3c47db388519629483dd8c3fce9694d4da6f"
Andrew Geissler82c905d2020-04-13 13:39:40 -050016
17# No point in hardcoding path to m4, just use PATH
18EXTRA_OECONF += "M4=m4"
19
Andrew Geissler82c905d2020-04-13 13:39:40 -050020inherit autotools gettext texinfo
21
22# The automatic m4 path detection gets confused, so force the right value
Andrew Geisslerb7d28612020-07-24 16:15:54 -050023acpaths = "-I ./m4"
Andrew Geissler82c905d2020-04-13 13:39:40 -050024
25do_compile_prepend() {
26 for i in mfcalc calc++ rpcalc; do mkdir -p ${B}/examples/$i; done
27}
28
29do_install_append_class-native() {
30 create_wrapper ${D}/${bindir}/bison \
31 BISON_PKGDATADIR=${STAGING_DATADIR_NATIVE}/bison
32}
33do_install_append_class-nativesdk() {
34 create_wrapper ${D}/${bindir}/bison \
35 BISON_PKGDATADIR=${datadir}/bison
36}
37BBCLASSEXTEND = "native nativesdk"