Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "A utility for finding interesting messages in log files" |
| 2 | DESCRIPTION = "Logwarn searches for interesting messages in log files, \ |
| 3 | where 'interesting' is defined by a user-supplied list of positive and \ |
| 4 | negative extended regular expressions. \ |
| 5 | " |
| 6 | HOMEPAGE = "https://github.com/archiecobbs/logwarn/wiki" |
| 7 | SECTION = "console/utils" |
| 8 | |
| 9 | LICENSE = "Apache-2.0" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| 11 | |
| 12 | SRC_URI = "https://s3.amazonaws.com/archie-public/${BPN}/${BP}.tar.gz" |
| 13 | |
| 14 | SRC_URI[md5sum] = "e544a6230673ea54f7430bf817bb39d8" |
| 15 | SRC_URI[sha256sum] = "8dbfcf9b28c782ab3bddd6a620d4fb95d1b0ffcbe93276996cdc4800aa9aebd1" |
| 16 | |
| 17 | inherit autotools-brokensep |
| 18 | |
| 19 | # This directory is NOT volatile. |
| 20 | # |
| 21 | lcl_default_state_dir = "${localstatedir}/lib/logwarn" |
| 22 | |
| 23 | CFLAGS += '-DDEFAULT_STATE_DIR=\""${lcl_default_state_dir}\""' |
| 24 | |
| 25 | CACHED_CONFIGUREVARS += " \ |
| 26 | ac_cv_path_BASH_SHELL=${base_bindir}/bash \ |
| 27 | ac_cv_path_CAT=${base_bindir}/cat \ |
| 28 | ac_cv_path_RM=${base_bindir}/rm \ |
| 29 | ac_cv_path_SED=${base_bindir}/sed \ |
| 30 | " |
| 31 | |
| 32 | # Make sure some files exist for autoreconf. |
| 33 | # |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 34 | do_configure:prepend () { |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 35 | touch ${S}/NEWS |
| 36 | touch ${S}/ChangeLog |
| 37 | touch ${S}/README |
| 38 | } |
| 39 | |
| 40 | # Create a directory for logfile state info, usually under /var/lib. |
| 41 | # |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 42 | do_install:append () { |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 43 | install -d ${D}${lcl_default_state_dir} |
| 44 | } |
| 45 | |
| 46 | # Make a package for the nagios plug-in (script). |
| 47 | # |
| 48 | PACKAGES += "${PN}-nagios" |
| 49 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 50 | FILES:${PN}-nagios = "${nonarch_libdir}/nagios" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 51 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 52 | RDEPENDS:${PN}-nagios += "bash coreutils sed" |