blob: 1d54b9f6af29060d84734ab4900a29828a0a16dc [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Python-apt is a wrapper to use features of apt from python."
2LICENSE = "GPL-2.0-only & FSFAP"
3LIC_FILES_CHKSUM = "file://COPYING.GPL;md5=0636e73ff0215e8d672dc4c32c317bb3 \
4 file://debian/copyright;md5=4ed7b6862ca422678b17e7d4ed592285"
5
6SRC_URI = "git://salsa.debian.org/apt-team/python-apt.git;protocol=https;branch=main"
7
Andrew Geisslerfc113ea2023-03-31 09:59:46 -05008SRCREV = "3252935b6224b3bd2e2250894b9559b47c61b2e1"
Andrew Geissler517393d2023-01-13 08:55:19 -06009
10S = "${WORKDIR}/git"
11
12inherit setuptools3
13
14DEPENDS += "apt"
15RDEPENDS:${PN} += "apt python3-core"
16
17FILES:${PN} = "${libdir} ${datadir}/python-apt"