blob: 0ec4de055c55429f21f7acbc5214bd7d245a930f [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Resolve JSON Pointers in Python"
2HOMEPAGE = "https://github.com/stefankoegl/python-json-pointer"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=32b15c843b7a329130f4e266a281ebb3"
5
6inherit pypi ptest setuptools3
7
Andrew Geisslerfc113ea2023-03-31 09:59:46 -05008SRC_URI += "file://0001-Clean-up-test-runner.patch"
9
Patrick Williams03907ee2022-05-01 06:28:52 -050010SRC_URI[sha256sum] = "97cba51526c829282218feb99dab1b1e6bdf8efd1c43dc9d57be093c0d69c99a"
Andrew Geissler595f6302022-01-24 19:11:47 +000011
12RDEPENDS:${PN} += " \
13 ${PYTHON_PN}-json \
14"
15
16BBCLASSEXTEND = "native nativesdk"
17
18SRC_URI += " \
19 file://run-ptest \
20"
21
22RDEPENDS:${PN}-ptest += " \
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050023 ${PYTHON_PN}-doctest \
24 ${PYTHON_PN}-unittest \
25 ${PYTHON_PN}-unittest-automake-output \
Andrew Geissler595f6302022-01-24 19:11:47 +000026"
27
28do_install_ptest() {
29 cp -f ${S}/tests.py ${D}${PTEST_PATH}/
30}