blob: e399f2139a7fa0c889c5ce6d45b498577075d956 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "World timezone definitions, modern and historical"
2HOMEPAGE = "http://pythonhosted.org/pytz"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=1a67fc46c1b596cce5d21209bbe75999"
5
6inherit pypi setuptools3 ptest
7
Patrick Williams864cc432023-02-09 14:54:44 -06008SRC_URI[sha256sum] = "01a0681c4b9684a28304615eba55d1ab31ae00bf68ec157ec3708a8182dbbcd0"
Andrew Geissler517393d2023-01-13 08:55:19 -06009
10RDEPENDS:${PN}:class-target += "\
11 ${PYTHON_PN}-datetime \
12 ${PYTHON_PN}-doctest \
13 ${PYTHON_PN}-io \
14 ${PYTHON_PN}-pickle \
15 ${PYTHON_PN}-pprint \
16 ${PYTHON_PN}-threading \
17"
18
19BBCLASSEXTEND = "native nativesdk"
20
21SRC_URI += " \
22 file://run-ptest \
23"
24
25RDEPENDS:${PN}-ptest += " \
26 ${PYTHON_PN}-pytest \
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050027 ${PYTHON_PN}-unittest-automake-output \
Andrew Geissler517393d2023-01-13 08:55:19 -060028"
29
30do_install_ptest() {
31 install -d ${D}${PTEST_PATH}/pytz
32 install -d ${D}${PTEST_PATH}/pytz/tests
33 cp -rf ${S}/pytz/tests/* ${D}${PTEST_PATH}/pytz/tests/
34 cp -f ${S}/README.rst ${D}${PTEST_PATH}/
35
36}