blob: 18649ceeafc287a56f95577f1a5d664d678e3827 [file] [log] [blame]
Patrick Williams8dd68482022-10-04 07:57:18 -05001SUMMARY = "External system Cortex-M3 Firmware"
2DESCRIPTION = "Firmware to be loaded and run in External System Harness in\
3 support to the main application CPU."
4HOMEPAGE = "https://git.linaro.org/landing-teams/working/arm/external-system.git"
5DEPENDS = "gcc-arm-none-eabi-native"
6INHIBIT_DEFAULT_DEPS="1"
7LICENSE = "BSD-3-Clause & Apache-2.0"
8LIC_FILES_CHKSUM = "file://license.md;md5=e44b2531cd6ffe9dece394dbe988d9a0 \
9 file://cmsis/LICENSE.txt;md5=e3fc50a88d0a364313df4b21ef20c29e"
10
Andrew Geissler9347dd42023-03-03 12:38:41 -060011SRC_URI = "gitsm://git.gitlab.arm.com/arm-reference-solutions/corstone1000/external_system/rtx.git;protocol=https;branch=master \
Andrew Geisslerfc7e7972023-09-11 08:24:07 -040012 file://0001-tools-gen_module_code-atomically-rewrite-the-generat.patch"
Patrick Williams8dd68482022-10-04 07:57:18 -050013SRCREV = "8c9dca74b104ff6c9722fb0738ba93dd3719c080"
Andrew Geisslerfc7e7972023-09-11 08:24:07 -040014PV .= "+git"
Patrick Williams8dd68482022-10-04 07:57:18 -050015
16COMPATIBLE_MACHINE = "(corstone1000)"
Andrew Geisslerfc7e7972023-09-11 08:24:07 -040017PACKAGE_ARCH = "${MACHINE_ARCH}"
Patrick Williams8dd68482022-10-04 07:57:18 -050018
19# PRODUCT is passed to the Makefile to specify the platform to be used.
20PRODUCT = "corstone-1000"
21
22S = "${WORKDIR}/git"
23B = "${WORKDIR}/build"
24
Patrick Williams520786c2023-06-25 16:20:36 -050025# remove once arm-none-eabi-gcc updates to 13 or newer like poky
26DEBUG_PREFIX_MAP:remove = "-fcanon-prefix-map"
27
Patrick Williams8dd68482022-10-04 07:57:18 -050028LDFLAGS[unexport] = "1"
29
30do_compile() {
31 oe_runmake -C ${S} V=y \
32 BUILD_PATH=${B} \
33 PRODUCT=${PRODUCT} \
34 CROSS_COMPILE=arm-none-eabi- \
35 all
36}
37
38do_compile[cleandirs] = "${B}"
39
40do_install() {
41 install -D -p -m 0644 ${B}/product/${PRODUCT}/firmware/release/bin/firmware.bin ${D}/firmware/es_flashfw.bin
42}
43
44FILES:${PN} = "/firmware"
45SYSROOT_DIRS += "/firmware"
46
47inherit deploy
48
49do_deploy() {
50 cp -rf ${D}/firmware/* ${DEPLOYDIR}/
51}
52addtask deploy after do_install