blob: 0edbfc1815a606ffd9fa3dd744ade24231a9da25 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001inherit siteinfo python3native
Brad Bishop316dfdd2018-06-25 12:45:53 -04002
3DEPENDS_append = " meson-native ninja-native"
4
5# As Meson enforces out-of-tree builds we can just use cleandirs
6B = "${WORKDIR}/build"
7do_configure[cleandirs] = "${B}"
8
9# Where the meson.build build configuration is
10MESON_SOURCEPATH = "${S}"
11
12def noprefix(var, d):
13 return d.getVar(var).replace(d.getVar('prefix') + '/', '', 1)
14
15MESONOPTS = " --prefix ${prefix} \
16 --buildtype plain \
17 --bindir ${@noprefix('bindir', d)} \
18 --sbindir ${@noprefix('sbindir', d)} \
19 --datadir ${@noprefix('datadir', d)} \
20 --libdir ${@noprefix('libdir', d)} \
21 --libexecdir ${@noprefix('libexecdir', d)} \
22 --includedir ${@noprefix('includedir', d)} \
23 --mandir ${@noprefix('mandir', d)} \
24 --infodir ${@noprefix('infodir', d)} \
25 --sysconfdir ${sysconfdir} \
26 --localstatedir ${localstatedir} \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080027 --sharedstatedir ${sharedstatedir} \
28 -Dc_args='${BUILD_CPPFLAGS} ${BUILD_CFLAGS}' \
29 -Dc_link_args='${BUILD_LDFLAGS}' \
30 -Dcpp_args='${BUILD_CPPFLAGS} ${BUILD_CXXFLAGS}' \
31 -Dcpp_link_args='${BUILD_LDFLAGS}'"
Brad Bishop316dfdd2018-06-25 12:45:53 -040032
33MESON_TOOLCHAIN_ARGS = "${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}"
34MESON_C_ARGS = "${MESON_TOOLCHAIN_ARGS} ${CFLAGS}"
35MESON_CPP_ARGS = "${MESON_TOOLCHAIN_ARGS} ${CXXFLAGS}"
36MESON_LINK_ARGS = "${MESON_TOOLCHAIN_ARGS} ${LDFLAGS}"
37
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080038EXTRA_OEMESON_append = " ${PACKAGECONFIG_CONFARGS}"
Brad Bishop316dfdd2018-06-25 12:45:53 -040039
40MESON_CROSS_FILE = ""
41MESON_CROSS_FILE_class-target = "--cross-file ${WORKDIR}/meson.cross"
42MESON_CROSS_FILE_class-nativesdk = "--cross-file ${WORKDIR}/meson.cross"
43
44def meson_array(var, d):
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080045 items = d.getVar(var).split()
46 return repr(items[0] if len(items) == 1 else items)
47
48# Map our ARCH values to what Meson expects:
49# http://mesonbuild.com/Reference-tables.html#cpu-families
50def meson_cpu_family(var, d):
51 import re
52 arch = d.getVar(var)
53 if arch == 'powerpc':
54 return 'ppc'
55 elif arch == 'powerpc64':
56 return 'ppc64'
Brad Bishop19323692019-04-05 15:28:33 -040057 elif arch == 'armeb':
58 return 'arm'
Brad Bishop15ae2502019-06-18 21:44:24 -040059 elif arch == 'aarch64_be':
60 return 'aarch64'
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080061 elif arch == 'mipsel':
62 return 'mips'
Brad Bishop19323692019-04-05 15:28:33 -040063 elif arch == 'mips64el':
64 return 'mips64'
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080065 elif re.match(r"i[3-6]86", arch):
66 return "x86"
67 else:
68 return arch
69
70def meson_endian(prefix, d):
71 arch, os = d.getVar(prefix + "_ARCH"), d.getVar(prefix + "_OS")
72 sitedata = siteinfo_data_for_machine(arch, os, d)
73 if "endian-little" in sitedata:
74 return "little"
75 elif "endian-big" in sitedata:
76 return "big"
77 else:
78 bb.fatal("Cannot determine endianism for %s-%s" % (arch, os))
Brad Bishop316dfdd2018-06-25 12:45:53 -040079
80addtask write_config before do_configure
81do_write_config[vardeps] += "MESON_C_ARGS MESON_CPP_ARGS MESON_LINK_ARGS CC CXX LD AR NM STRIP READELF"
82do_write_config() {
83 # This needs to be Py to split the args into single-element lists
84 cat >${WORKDIR}/meson.cross <<EOF
85[binaries]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080086c = ${@meson_array('CC', d)}
87cpp = ${@meson_array('CXX', d)}
88ar = ${@meson_array('AR', d)}
89nm = ${@meson_array('NM', d)}
90ld = ${@meson_array('LD', d)}
91strip = ${@meson_array('STRIP', d)}
92readelf = ${@meson_array('READELF', d)}
Brad Bishop316dfdd2018-06-25 12:45:53 -040093pkgconfig = 'pkg-config'
Brad Bishop19323692019-04-05 15:28:33 -040094llvm-config = 'llvm-config8.0.0'
Brad Bishop316dfdd2018-06-25 12:45:53 -040095
96[properties]
97needs_exe_wrapper = true
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080098c_args = ${@meson_array('MESON_C_ARGS', d)}
99c_link_args = ${@meson_array('MESON_LINK_ARGS', d)}
100cpp_args = ${@meson_array('MESON_CPP_ARGS', d)}
101cpp_link_args = ${@meson_array('MESON_LINK_ARGS', d)}
Brad Bishop316dfdd2018-06-25 12:45:53 -0400102gtkdoc_exe_wrapper = '${B}/gtkdoc-qemuwrapper'
103
104[host_machine]
105system = '${HOST_OS}'
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800106cpu_family = '${@meson_cpu_family('HOST_ARCH', d)}'
Brad Bishop316dfdd2018-06-25 12:45:53 -0400107cpu = '${HOST_ARCH}'
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800108endian = '${@meson_endian('HOST', d)}'
Brad Bishop316dfdd2018-06-25 12:45:53 -0400109
110[target_machine]
111system = '${TARGET_OS}'
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800112cpu_family = '${@meson_cpu_family('TARGET_ARCH', d)}'
Brad Bishop316dfdd2018-06-25 12:45:53 -0400113cpu = '${TARGET_ARCH}'
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800114endian = '${@meson_endian('TARGET', d)}'
Brad Bishop316dfdd2018-06-25 12:45:53 -0400115EOF
116}
117
118CONFIGURE_FILES = "meson.build"
119
120meson_do_configure() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800121 # Work around "Meson fails if /tmp is mounted with noexec #2972"
122 mkdir -p "${B}/meson-private/tmp"
123 export TMPDIR="${B}/meson-private/tmp"
124 bbnote Executing meson ${EXTRA_OEMESON}...
Brad Bishop316dfdd2018-06-25 12:45:53 -0400125 if ! meson ${MESONOPTS} "${MESON_SOURCEPATH}" "${B}" ${MESON_CROSS_FILE} ${EXTRA_OEMESON}; then
Brad Bishop316dfdd2018-06-25 12:45:53 -0400126 bbfatal_log meson failed
127 fi
128}
129
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800130override_native_tools() {
Brad Bishop316dfdd2018-06-25 12:45:53 -0400131 # Set these so that meson uses the native tools for its build sanity tests,
132 # which require executables to be runnable. The cross file will still
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800133 # override these for the target build.
Brad Bishop316dfdd2018-06-25 12:45:53 -0400134 export CC="${BUILD_CC}"
135 export CXX="${BUILD_CXX}"
136 export LD="${BUILD_LD}"
137 export AR="${BUILD_AR}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800138 # These contain *target* flags but will be used as *native* flags. The
139 # correct native flags will be passed via -Dc_args and so on, unset them so
140 # they don't interfere with tools invoked by Meson (such as g-ir-scanner)
141 unset CPPFLAGS CFLAGS CXXFLAGS LDFLAGS
142}
143
144meson_do_configure_prepend_class-target() {
145 override_native_tools
Brad Bishop316dfdd2018-06-25 12:45:53 -0400146}
147
148meson_do_configure_prepend_class-nativesdk() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800149 override_native_tools
Brad Bishop316dfdd2018-06-25 12:45:53 -0400150}
151
152meson_do_configure_prepend_class-native() {
153 export PKG_CONFIG="pkg-config-native"
154}
155
156do_compile[progress] = "outof:^\[(\d+)/(\d+)\]\s+"
157meson_do_compile() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800158 ninja -v ${PARALLEL_MAKE}
Brad Bishop316dfdd2018-06-25 12:45:53 -0400159}
160
161meson_do_install() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800162 DESTDIR='${D}' ninja -v ${PARALLEL_MAKEINST} install
Brad Bishop316dfdd2018-06-25 12:45:53 -0400163}
164
165EXPORT_FUNCTIONS do_configure do_compile do_install