blob: 7970cd953f41e00790c526401bbc0a9be118b53b [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "Unicode Character Database"
2HOMEPAGE = "https://unicode.org/ucd/"
3LICENSE = "MIT"
Andrew Geissler028142b2023-05-05 11:29:21 -05004LIC_FILES_CHKSUM = "file://${WORKDIR}/license.txt;md5=4b11b5cbb0a24df9f4e7db63db98f22f"
Andrew Geisslereff27472021-10-29 15:35:00 -05005
6SRC_URI = " \
Andrew Geissler595f6302022-01-24 19:11:47 +00007 https://www.unicode.org/Public/zipped/${PV}/UCD.zip;name=ucd;subdir=ucd;downloadfilename=unicode-ucd-${PV}.zip \
Andrew Geissler028142b2023-05-05 11:29:21 -05008 https://www.unicode.org/license.txt;name=ucd-license \
Andrew Geisslereff27472021-10-29 15:35:00 -05009"
10SRC_URI[ucd.sha256sum] = "033a5276b5d7af8844589f8e3482f3977a8385e71d107d375055465178c23600"
Andrew Geissler028142b2023-05-05 11:29:21 -050011SRC_URI[ucd-license.sha256sum] = "f7830d126f59d83842565d3dddedc79db4ca978ed52aee0ebcc040ea76a85519"
Andrew Geisslereff27472021-10-29 15:35:00 -050012
13inherit allarch
14
15do_configure[noexec] = "1"
16
17do_install() {
18 install -d ${D}${datadir}/unicode
19 cp -rf ${WORKDIR}/ucd ${D}${datadir}/unicode
20}
21
22FILES:${PN} = "${datadir}/unicode/ucd"