blob: acaec73aa191a5019a6c70ac27e0df49596d5ed0 [file] [log] [blame]
Matt Spinler1b8b9042016-08-25 13:04:09 -05001SUMMARY = "Phosphor machine readable workbook patching script"
2DESCRIPTION = "Retrieve the script that can patch the MRW XML"
3PR = "r1"
4
5S = "${WORKDIR}/git"
6
7inherit obmc-phosphor-license
8inherit native
Matt Spinlerb103a332016-09-15 10:39:43 -05009inherit mrw-rev
Matt Spinler1b8b9042016-08-25 13:04:09 -050010
11DEPENDS += "python-native python-lxml-native"
12
Patrick Williams87880c82016-10-31 15:46:40 -050013SRC_URI += "${MRW_TOOLS_SRC_URI}"
14SRCREV = "${MRW_TOOLS_SRCREV}"
Matt Spinler1b8b9042016-08-25 13:04:09 -050015
16do_install() {
Matt Spinler98c33e32016-09-20 13:32:44 -050017 install -d ${D}${bindir}/obmc-mrw
18 install -m 0755 patchxml.py ${D}${bindir}/obmc-mrw
Matt Spinler1b8b9042016-08-25 13:04:09 -050019}