blob: 58e1f41be536085964d279c3f667b91ab28fa64c [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Framework for layout and rendering of internationalized text"
2DESCRIPTION = "Pango is a library for laying out and rendering of text, \
3with an emphasis on internationalization. Pango can be used anywhere \
4that text layout is needed, though most of the work on Pango so far has \
5been done in the context of the GTK+ widget toolkit. Pango forms the \
6core of text and font handling for GTK+-2.x."
7HOMEPAGE = "http://www.pango.org/"
8BUGTRACKER = "http://bugzilla.gnome.org"
9SECTION = "libs"
10LICENSE = "LGPLv2.0+"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
13
Brad Bishop19323692019-04-05 15:28:33 -040014GNOMEBASEBUILDCLASS = "meson"
15
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080016inherit gnomebase gtk-doc ptest-gnome upstream-version-is-even gobject-introspection
17
18SRC_URI += "file://run-ptest \
Brad Bishop19323692019-04-05 15:28:33 -040019 file://insensitive-diff.patch"
20
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080021SRC_URI[archive.md5sum] = "deb171a31a3ad76342d5195a1b5bbc7c"
22SRC_URI[archive.sha256sum] = "1d2b74cd63e8bd41961f2f8d952355aa0f9be6002b52c8aa7699d9f5da597c9d"
23
24DEPENDS = "glib-2.0 glib-2.0-native fontconfig freetype virtual/libiconv cairo harfbuzz fribidi"
25
26PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
Brad Bishop19323692019-04-05 15:28:33 -040027PACKAGECONFIG[x11] = ",,virtual/libx11 libxft"
28
Brad Bishopc342db32019-05-15 21:57:59 -040029GTKDOC_MESON_OPTION = "enable_docs"
30GIR_MESON_OPTION = 'gir'
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080031
32LEAD_SONAME = "libpango-1.0*"
33LIBV = "1.8.0"
34
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080035FILES_${PN} = "${bindir}/* ${libdir}/libpango*${SOLIBS}"
36FILES_${PN}-dev += "${libdir}/pango/${LIBV}/modules/*.la"
37
38RDEPENDS_${PN}-ptest += "liberation-fonts cantarell-fonts"
39
40RPROVIDES_${PN} += "pango-modules pango-module-indic-lang \
41 pango-module-basic-fc pango-module-arabic-lang"
42
Brad Bishop19323692019-04-05 15:28:33 -040043BBCLASSEXTEND = "native nativesdk"
44
45do_install_append () {
46 if [ "${PTEST_ENABLED}" != "1" ]; then
47 rm -rf ${D}${libexecdir}/installed-tests ${D}${datadir}/installed-tests
48 rmdir --ignore-fail-on-non-empty ${D}${libexecdir} ${D}${datadir}
49 fi
50}