blob: 592633bcfdb0cb50004f44af7ad5a77dfeedc0d3 [file] [log] [blame]
Matt Spinleraca1b152017-03-10 15:08:56 -06001SUMMARY = "OpenPower procedure control"
2DESCRIPTION = "Provides procedures that run against the host chipset"
3PR = "r1"
Patrick Venture8eb23612018-10-02 19:14:43 -07004PV = "1.0+git${SRCPV}"
Matt Spinler37619cc2017-10-04 13:07:06 -05005LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
7
Matt Spinleraca1b152017-03-10 15:08:56 -06008S = "${WORKDIR}/git"
9
Andrew Geissler643013c2018-11-20 03:20:12 +000010inherit autotools obmc-phosphor-utils pkgconfig pythonnative
11inherit systemd
Matt Spinleraca1b152017-03-10 15:08:56 -060012
Matt Spinler37619cc2017-10-04 13:07:06 -050013SRC_URI += "git://github.com/openbmc/openpower-proc-control"
Lakshminarayana R. Kammath4378a3f2019-06-11 12:37:25 -050014SRCREV = "16ab00cb9383b17b8dd033a1cb300e2a013d55b1"
Matt Spinler20c9cd02017-09-18 15:52:40 -050015
16DEPENDS += " \
17 autoconf-archive-native \
18 phosphor-logging \
19 phosphor-dbus-interfaces \
20 openpower-dbus-interfaces \
21 "
Lakshminarayana R. Kammath4378a3f2019-06-11 12:37:25 -050022RDEPENDS_${PN} += "pdbg"
Matt Spinler20c9cd02017-09-18 15:52:40 -050023
Andrew Geissler643013c2018-11-20 03:20:12 +000024TEMPLATE = "pcie-poweroff@.service"
25INSTANCE_FORMAT = "pcie-poweroff@{}.service"
26INSTANCES = "${@compose_list(d, 'INSTANCE_FORMAT', 'OBMC_CHASSIS_INSTANCES')}"
27SYSTEMD_PACKAGES = "${PN}"
28SYSTEMD_SERVICE_${PN} = "${TEMPLATE} ${INSTANCES}"
Lakshminarayana R. Kammath4378a3f2019-06-11 12:37:25 -050029
30SYSTEMD_SERVICE_${PN} += " \
31 xyz.openbmc_project.Control.Host.NMI.service \
32 nmi.service \
33 "