blob: 9ebe164d8bf950a67d5a1111e9ee74ead7320655 [file] [log] [blame]
Nick Bofferdingf390b6f2019-10-08 11:55:42 -05001################################################################################
2#
3# SBE for P10
4#
5################################################################################
6
7SBE_P10_VERSION = $(call qstrip,$(BR2_SBE_P10_VERSION))
8# TODO: WORKAROUND: Need to reenable next line and comment out the two lines
9# after that, when code is propagated to a public repo
Nicholas E Bofferdingb607cf22019-11-14 00:05:44 -060010#SBE_P10_SITE ?= $(call github,open-power,sbe,$(SBE_P10_VERSION))
11SBE_P10_SITE ?= git@github.ibm.com:open-power/sbe.git
Nick Bofferdinge2293ba2019-11-14 14:38:29 -060012SBE_P10_SITE_METHOD ?= git
Nick Bofferdingf390b6f2019-10-08 11:55:42 -050013
14SBE_P10_LICENSE = Apache-2.0
15SBE_P10_DEPENDENCIES = host-ppe42-gcc hcode-p10
16# TODO WORKAROUND ... host-ppe42-gc not compiling
17# host-ppe42-gcc hcode-p10
18
19SBE_P10_INSTALL_IMAGES = YES
20SBE_P10_INSTALL_TARGET = NO
21
22define SBE_P10_BUILD_CMDS
23 SBE_COMMIT_ID=$(SBE_P10_VERSION) $(MAKE) -C $(@D) \
24 LD_LIBRARY_PATH=$(HOST_DIR)/usr/lib \
25 CROSS_COMPILER_PATH=$(PPE42_GCC_BIN) \
26 all
27endef
28
29define SBE_P10_INSTALL_IMAGES_CMDS
30 $(INSTALL) -D $(@D)/images/ipl_image_tool $(HOST_DIR)/usr/bin/
31 python $(@D)/src/build/sbeOpDistribute.py --sbe_binary_dir=$(STAGING_DIR)/sbe_binaries --img_dir=$(@D)/images --sbe_binary_filename $(BR2_HOSTBOOT_BINARY_SBE_FILENAME)
32 cp $(@D)/src/build/sbeOpDistribute.py $(STAGING_DIR)/sbe_binaries/
hostboot717192c2020-02-20 06:05:18 -060033 cp $(@D)/src/build/sbeOpToolsRegister.py $(STAGING_DIR)/sbe_binaries/
Nick Bofferdingf390b6f2019-10-08 11:55:42 -050034endef
35
36$(eval $(generic-package))