Nick Bofferding | f390b6f | 2019-10-08 11:55:42 -0500 | [diff] [blame] | 1 | ################################################################################ |
| 2 | # |
| 3 | # SBE for P10 |
| 4 | # |
| 5 | ################################################################################ |
| 6 | |
| 7 | SBE_P10_VERSION = $(call qstrip,$(BR2_SBE_P10_VERSION)) |
| 8 | # TODO: WORKAROUND: Need to reenable next line and comment out the two lines |
| 9 | # after that, when code is propagated to a public repo |
Nicholas E Bofferding | b607cf2 | 2019-11-14 00:05:44 -0600 | [diff] [blame^] | 10 | #SBE_P10_SITE ?= $(call github,open-power,sbe,$(SBE_P10_VERSION)) |
| 11 | SBE_P10_SITE ?= git@github.ibm.com:open-power/sbe.git |
Nick Bofferding | f390b6f | 2019-10-08 11:55:42 -0500 | [diff] [blame] | 12 | |
| 13 | SBE_P10_LICENSE = Apache-2.0 |
| 14 | SBE_P10_DEPENDENCIES = host-ppe42-gcc hcode-p10 |
| 15 | # TODO WORKAROUND ... host-ppe42-gc not compiling |
| 16 | # host-ppe42-gcc hcode-p10 |
| 17 | |
| 18 | SBE_P10_INSTALL_IMAGES = YES |
| 19 | SBE_P10_INSTALL_TARGET = NO |
| 20 | |
| 21 | define SBE_P10_BUILD_CMDS |
| 22 | SBE_COMMIT_ID=$(SBE_P10_VERSION) $(MAKE) -C $(@D) \ |
| 23 | LD_LIBRARY_PATH=$(HOST_DIR)/usr/lib \ |
| 24 | CROSS_COMPILER_PATH=$(PPE42_GCC_BIN) \ |
| 25 | all |
| 26 | endef |
| 27 | |
| 28 | define SBE_P10_INSTALL_IMAGES_CMDS |
| 29 | $(INSTALL) -D $(@D)/images/ipl_image_tool $(HOST_DIR)/usr/bin/ |
| 30 | python $(@D)/src/build/sbeOpDistribute.py --sbe_binary_dir=$(STAGING_DIR)/sbe_binaries --img_dir=$(@D)/images --sbe_binary_filename $(BR2_HOSTBOOT_BINARY_SBE_FILENAME) |
| 31 | cp $(@D)/src/build/sbeOpDistribute.py $(STAGING_DIR)/sbe_binaries/ |
| 32 | endef |
| 33 | |
| 34 | $(eval $(generic-package)) |