blob: 31496ccddd78a6780910af5a5746f213a35c6224 [file] [log] [blame]
Matt Ploetzc19ce762016-09-01 18:18:56 -05001################################################################################
2#
3# ppe42-gcc
4#
5################################################################################
6
Nick Bofferdingf390b6f2019-10-08 11:55:42 -05007PPE42_GCC_VERSION ?= 3d454701206d141a26777c3f6c1d966921f363de
Matt Ploetzc19ce762016-09-01 18:18:56 -05008PPE42_GCC_SITE ?= $(call github,open-power,ppe42-gcc,$(PPE42_GCC_VERSION))
9PPE42_GCC_LICENSE = GPLv3+
10
William A. Kennington IIIb2ef6112017-04-14 15:56:20 -070011PPE42_GCC_DEPENDENCIES = ppe42-binutils gmp mpfr mpc
12HOST_PPE42_GCC_DEPENDENCIES = host-ppe42-binutils host-gmp host-mpfr host-mpc
Matt Ploetzc19ce762016-09-01 18:18:56 -050013
14PPE42_GCC_DIR = $(STAGING_DIR)/ppe42-binutils
15PPE42_GCC_BIN = $(STAGING_DIR)/ppe42-binutils/linux
16
17define HOST_PPE42_GCC_BUILD_CMDS
18 cd $(@D) && \
19 ./configure --prefix=$(PPE42_GCC_DIR) \
20 --exec-prefix=$(PPE42_GCC_BIN) \
Doug Gilbert9a438d02016-10-31 13:43:07 -050021 --target=powerpc-eabi \
22 --without-headers \
23 --with-newlib \
24 --with-gnu-as \
25 --with-gnu-ld \
26 --with-gmp=$(HOST_DIR)/usr \
27 --with-mpfr=$(HOST_DIR)/usr \
28 && \
Stewart Smithaa697d02017-02-17 18:49:10 +110029 $(MAKE) configure-host && \
30 $(MAKE) CFLAGS=-Wno-error all-gcc
Matt Ploetzc19ce762016-09-01 18:18:56 -050031endef
32
33define HOST_PPE42_GCC_INSTALL_CMDS
34 bash -c 'cd $(@D) && make install-gcc'
35endef
36
37$(eval $(host-generic-package))