blob: a59071d1ad6ce4ef029864b58298bdc038e71b00 [file] [log] [blame]
Matt Ploetzc19ce762016-09-01 18:18:56 -05001################################################################################
2#
3# ppe42-gcc
4#
5################################################################################
6
Klaus Heinrich Kiwi0b9616d2019-10-29 18:28:45 -03007PPE42_GCC_VERSION ?= b4772a9fa65ea0dd812f8f305ce157bb1cb5ab4a
Matt Ploetzc19ce762016-09-01 18:18:56 -05008PPE42_GCC_SITE ?= $(call github,open-power,ppe42-gcc,$(PPE42_GCC_VERSION))
9PPE42_GCC_LICENSE = GPLv3+
10
William A. Kennington IIIb2ef6112017-04-14 15:56:20 -070011PPE42_GCC_DEPENDENCIES = ppe42-binutils gmp mpfr mpc
12HOST_PPE42_GCC_DEPENDENCIES = host-ppe42-binutils host-gmp host-mpfr host-mpc
Klaus Heinrich Kiwidc4a86f2020-05-11 16:29:14 -030013PPE42_GCC_PROVIDES = ppe42-toolchain
Matt Ploetzc19ce762016-09-01 18:18:56 -050014
15PPE42_GCC_DIR = $(STAGING_DIR)/ppe42-binutils
16PPE42_GCC_BIN = $(STAGING_DIR)/ppe42-binutils/linux
17
18define HOST_PPE42_GCC_BUILD_CMDS
19 cd $(@D) && \
20 ./configure --prefix=$(PPE42_GCC_DIR) \
21 --exec-prefix=$(PPE42_GCC_BIN) \
Doug Gilbert9a438d02016-10-31 13:43:07 -050022 --target=powerpc-eabi \
23 --without-headers \
24 --with-newlib \
25 --with-gnu-as \
26 --with-gnu-ld \
27 --with-gmp=$(HOST_DIR)/usr \
28 --with-mpfr=$(HOST_DIR)/usr \
29 && \
Stewart Smithaa697d02017-02-17 18:49:10 +110030 $(MAKE) configure-host && \
31 $(MAKE) CFLAGS=-Wno-error all-gcc
Matt Ploetzc19ce762016-09-01 18:18:56 -050032endef
33
34define HOST_PPE42_GCC_INSTALL_CMDS
35 bash -c 'cd $(@D) && make install-gcc'
36endef
37
38$(eval $(host-generic-package))