| SUMMARY = "A lil' TOML parser" |
| DESCRIPTION = "Tomli is a Python library for parsing TOML. Tomli is fully \ |
| compatible with TOML v1.0.0." |
| HOMEPAGE = "https://github.com/hukkin/tomli" |
| BUGTRACKER = "https://github.com/hukkin/tomli/issues" |
| LICENSE = "MIT" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=aaaaf0879d17df0110d1aa8c8c9f46f5" |
| |
| inherit pypi setuptools3 |
| |
| SRC_URI[sha256sum] = "de526c12914f0c550d15924c62d72abc48d6fe7364aa87328337a31007fe8a4f" |
| |
| do_configure:prepend() { |
| cat > ${S}/setup.py <<-EOF |
| from setuptools import setup |
| setup(name="tomli", version="${PV}", packages=["tomli"], package_dir={'tomli': 'src/tomli'}, package_data={"": ["*"]}) |
| EOF |
| } |
| |
| BBCLASSEXTEND = "native nativesdk" |