Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame^] | 1 | SUMMARY = "A lil' TOML parser" |
| 2 | DESCRIPTION = "Tomli is a Python library for parsing TOML. Tomli is fully \ |
| 3 | compatible with TOML v1.0.0." |
| 4 | HOMEPAGE = "https://github.com/hukkin/tomli" |
| 5 | BUGTRACKER = "https://github.com/hukkin/tomli/issues" |
| 6 | LICENSE = "MIT" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=aaaaf0879d17df0110d1aa8c8c9f46f5" |
| 8 | |
| 9 | inherit pypi setuptools3 |
| 10 | |
| 11 | SRC_URI[sha256sum] = "de526c12914f0c550d15924c62d72abc48d6fe7364aa87328337a31007fe8a4f" |
| 12 | |
| 13 | do_configure:prepend() { |
| 14 | cat > ${S}/setup.py <<-EOF |
| 15 | from setuptools import setup |
| 16 | setup(name="tomli", version="${PV}", packages=["tomli"], package_dir={'tomli': 'src/tomli'}, package_data={"": ["*"]}) |
| 17 | EOF |
| 18 | } |
| 19 | |
| 20 | BBCLASSEXTEND = "native nativesdk" |