| SUMMARY = "Count blank lines, comment lines, and physical lines of source code \ |
| in many programming languages." |
| AUTHOR = "Al Danial" |
| |
| LICENSE="GPL-2.0" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=2c1c00f9d3ed9e24fa69b932b7e7aff2" |
| |
| SRC_URI = "https://github.com/AlDanial/cloc/releases/download/${PV}/${BP}.tar.gz" |
| SRC_URI[md5sum] = "a52f3843825377cfa4e4b3b30a567ab4" |
| SRC_URI[sha256sum] = "c3f0a6bd2319110418ccb3e55a7a1b6d0edfd7528bfd2ae5d530938abe90f254" |
| |
| do_configure[noexec] = "1" |
| do_compile[noexec] = "1" |
| |
| do_install() { |
| install -D -m 0755 ${S}/cloc ${D}${bindir}/cloc |
| } |
| |
| RDEPENDS_${PN} = "perl perl-modules" |