blob: f9ecd0ee44e73401298fa8d82be6f24df61f2f05 [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001SUMMARY = "Count blank lines, comment lines, and physical lines of source code \
2in many programming languages."
3AUTHOR = "Al Danial"
4
5LICENSE="GPL-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=2c1c00f9d3ed9e24fa69b932b7e7aff2"
7
8SRC_URI = "https://github.com/AlDanial/cloc/releases/download/${PV}/${BP}.tar.gz"
9SRC_URI[md5sum] = "a52f3843825377cfa4e4b3b30a567ab4"
10SRC_URI[sha256sum] = "c3f0a6bd2319110418ccb3e55a7a1b6d0edfd7528bfd2ae5d530938abe90f254"
11
12do_configure[noexec] = "1"
13do_compile[noexec] = "1"
14
15do_install() {
16 install -D -m 0755 ${S}/cloc ${D}${bindir}/cloc
17}
18
19RDEPENDS_${PN} = "perl perl-modules"