Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame^] | 1 | SUMMARY = "Count blank lines, comment lines, and physical lines of source code \ |
| 2 | in many programming languages." |
| 3 | AUTHOR = "Al Danial" |
| 4 | |
| 5 | LICENSE="GPL-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2c1c00f9d3ed9e24fa69b932b7e7aff2" |
| 7 | |
| 8 | SRC_URI = "https://github.com/AlDanial/cloc/releases/download/${PV}/${BP}.tar.gz" |
| 9 | SRC_URI[md5sum] = "a52f3843825377cfa4e4b3b30a567ab4" |
| 10 | SRC_URI[sha256sum] = "c3f0a6bd2319110418ccb3e55a7a1b6d0edfd7528bfd2ae5d530938abe90f254" |
| 11 | |
| 12 | do_configure[noexec] = "1" |
| 13 | do_compile[noexec] = "1" |
| 14 | |
| 15 | do_install() { |
| 16 | install -D -m 0755 ${S}/cloc ${D}${bindir}/cloc |
| 17 | } |
| 18 | |
| 19 | RDEPENDS_${PN} = "perl perl-modules" |