| DESCRIPTION = "A small C library that is supposed to make it easy to run an HTTP server as part of another application" |
| HOMEPAGE = "http://www.gnu.org/software/libmicrohttpd/" |
| LICENSE = "LGPL-2.1+" |
| LIC_FILES_CHKSUM = "file://COPYING;md5=57d09285feac8a64efa878e692b14f36" |
| SECTION = "net" |
| |
| DEPENDS = "file" |
| |
| SRC_URI = "${GNU_MIRROR}/libmicrohttpd/${BPN}-${PV}.tar.gz \ |
| " |
| SRC_URI[md5sum] = "1c3ca3bf92dfc680538b4186c58a9bd0" |
| SRC_URI[sha256sum] = "c5716e2a2899abc9e16c8fa7a1a58da88f81aca96a0b7e68a5d4d89e21610b61" |
| |
| inherit autotools lib_package pkgconfig gettext |
| |
| CFLAGS += "-pthread -D_REENTRANT" |
| |
| EXTRA_OECONF += "--disable-static --with-gnutls=${STAGING_LIBDIR}/../" |
| |
| PACKAGECONFIG ?= "curl https" |
| PACKAGECONFIG_append_class-target = "\ |
| ${@bb.utils.filter('DISTRO_FEATURES', 'largefile', d)} \ |
| " |
| PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,," |
| PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl," |
| PACKAGECONFIG[https] = "--enable-https,--disable-https,libgcrypt gnutls," |
| |
| do_compile_append() { |
| sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc |
| } |