Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | DESCRIPTION = "A small C library that is supposed to make it easy to run an HTTP server as part of another application" |
| 2 | HOMEPAGE = "http://www.gnu.org/software/libmicrohttpd/" |
| 3 | LICENSE = "LGPL-2.1+" |
Brad Bishop | b809eb9 | 2019-09-18 06:27:43 -0400 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=57d09285feac8a64efa878e692b14f36" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 5 | SECTION = "net" |
Brad Bishop | b809eb9 | 2019-09-18 06:27:43 -0400 | [diff] [blame] | 6 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 7 | DEPENDS = "file" |
| 8 | |
Brad Bishop | 779d0ac | 2019-09-27 08:23:48 -0400 | [diff] [blame] | 9 | SRC_URI = "${GNU_MIRROR}/libmicrohttpd/${BPN}-${PV}.tar.gz \ |
Brad Bishop | 779d0ac | 2019-09-27 08:23:48 -0400 | [diff] [blame] | 10 | " |
Brad Bishop | 996bc45 | 2019-12-02 13:05:15 -0500 | [diff] [blame] | 11 | SRC_URI[md5sum] = "1c3ca3bf92dfc680538b4186c58a9bd0" |
| 12 | SRC_URI[sha256sum] = "c5716e2a2899abc9e16c8fa7a1a58da88f81aca96a0b7e68a5d4d89e21610b61" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 13 | |
| 14 | inherit autotools lib_package pkgconfig gettext |
| 15 | |
| 16 | CFLAGS += "-pthread -D_REENTRANT" |
| 17 | |
| 18 | EXTRA_OECONF += "--disable-static --with-gnutls=${STAGING_LIBDIR}/../" |
| 19 | |
| 20 | PACKAGECONFIG ?= "curl https" |
| 21 | PACKAGECONFIG_append_class-target = "\ |
| 22 | ${@bb.utils.filter('DISTRO_FEATURES', 'largefile', d)} \ |
| 23 | " |
| 24 | PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,," |
| 25 | PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl," |
| 26 | PACKAGECONFIG[https] = "--enable-https,--disable-https,libgcrypt gnutls," |
| 27 | |
| 28 | do_compile_append() { |
| 29 | sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc |
| 30 | } |