| SUMMARY = "Line-oriented text editor" |
| HOMEPAGE = "http://www.gnu.org/software/ed/" |
| |
| LICENSE = "GPLv3+" |
| LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949 \ |
| file://ed.h;endline=20;md5=375a20cc2545ac1115eeb7b323c60ae3 \ |
| file://main.c;endline=17;md5=14dbb325c1f2d4daf50e0aa5c5038e96" |
| |
| SECTION = "base" |
| |
| # LSB states that ed should be in /bin/ |
| bindir = "${base_bindir}" |
| |
| SRC_URI = "${GNU_MIRROR}/ed/ed-${PV}.tar.gz" |
| |
| SRC_URI[md5sum] = "565b6d1d5a9a8816b9b304fc4ed9405d" |
| SRC_URI[sha256sum] = "d5b372cfadf073001823772272fceac2cfa87552c5cd5a8efc1c8aae61f45a88" |
| |
| inherit texinfo |
| |
| do_configure() { |
| ${S}/configure |
| } |
| |
| do_install() { |
| oe_runmake 'DESTDIR=${D}' install |
| # Info dir listing isn't interesting at this point so remove it if it exists. |
| if [ -e "${D}${infodir}/dir" ]; then |
| rm -f ${D}${infodir}/dir |
| fi |
| } |