Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 1 | SUMMARY = "Count blank lines, comment lines, and physical lines of source code \ |
| 2 | in many programming languages." |
| 3 | AUTHOR = "Al Danial" |
| 4 | |
| 5 | LICENSE="GPL-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2c1c00f9d3ed9e24fa69b932b7e7aff2" |
| 7 | |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 8 | SRC_URI = "https://github.com/AlDanial/cloc/releases/download/v${PV}/${BP}.tar.gz" |
| 9 | SRC_URI[md5sum] = "e2364c2c9c9eda1d20890c19911c51fb" |
| 10 | SRC_URI[sha256sum] = "152502a61d4bae4a406a05a01bf52489b310ec03dbd8c645d0bb051fa4717ddb" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 11 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 12 | UPSTREAM_CHECK_URI = "https://github.com/AlDanial/${BPN}/releases" |
| 13 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 14 | do_configure[noexec] = "1" |
| 15 | do_compile[noexec] = "1" |
| 16 | |
| 17 | do_install() { |
| 18 | install -D -m 0755 ${S}/cloc ${D}${bindir}/cloc |
| 19 | } |
| 20 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 21 | RDEPENDS:${PN} = "perl perl-modules" |