Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Character Based User Interface for libyui" |
| 2 | LICENSE = "LGPLv3" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING.lgpl-3;md5=e6a600fd5e1d9cbde2d983680233ad02 \ |
| 4 | file://COPYING.lgpl-2.1;md5=4fbd65380cdd255951079008b364516c \ |
| 5 | " |
| 6 | |
| 7 | SRC_URI = "git://github.com/libyui/libyui-ncurses.git \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 8 | file://0003-Simplify-ncurses-finding-module.patch \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 9 | " |
| 10 | |
| 11 | SRC_URI_append_class-target = " file://0001-Fix-the-error-of-can-t-find-header-file.patch" |
| 12 | |
Brad Bishop | 779d0ac | 2019-09-27 08:23:48 -0400 | [diff] [blame] | 13 | SRCREV = "d5b64b6291b6f292871ad5c6df25c4f6896f7d50" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | inherit cmake gettext pkgconfig |
| 18 | |
| 19 | DEPENDS += "boost libyui ncurses" |
| 20 | |
| 21 | BBCLASSEXTEND = "nativesdk" |
| 22 | |
| 23 | do_configure_prepend () { |
| 24 | cd ${S} |
| 25 | git checkout bootstrap.sh |
| 26 | sed -i "s#/usr#${PKG_CONFIG_SYSROOT_DIR}${base_prefix}&#" bootstrap.sh |
| 27 | ./bootstrap.sh |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 28 | if [ -e ${PKG_CONFIG_SYSROOT_DIR}${base_prefix}/usr/lib/libyui.so ]; then |
| 29 | mkdir -p ${PKG_CONFIG_SYSROOT_DIR}${base_prefix}/usr/lib64/ |
| 30 | cp ${PKG_CONFIG_SYSROOT_DIR}${base_prefix}/usr/lib/libyui.so* ${PKG_CONFIG_SYSROOT_DIR}${base_prefix}/usr/lib64/ |
| 31 | fi |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 32 | cd - |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 33 | sed -i -e "s#\${YPREFIX}#\${PKG_CONFIG_SYSROOT_DIR}${base_prefix}&#" ${S}/CMakeLists.txt |
| 34 | sed -i -e "s#/usr#${PKG_CONFIG_SYSROOT_DIR}${base_prefix}&#" ${PKG_CONFIG_SYSROOT_DIR}${libdir}/cmake/libyui/LibyuiLibraryDepends-release.cmake |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 35 | } |
| 36 | |
| 37 | do_install_append () { |
| 38 | if [ "${libdir}" = "${base_prefix}/usr/lib" ] && [ -d ${D}/usr/lib64 ]; then |
| 39 | mv ${D}/usr/lib64 ${D}/usr/lib |
| 40 | fi |
| 41 | } |
| 42 | |
| 43 | do_install_append_class-nativesdk () { |
| 44 | mkdir -p ${D}/${base_prefix} |
| 45 | mv ${D}/usr ${D}/${base_prefix} |
| 46 | } |
| 47 | |
| 48 | FILES_${PN} += "${datadir}/*" |
| 49 | |
| 50 | FILES_${PN}-dev += "${libdir}/*" |