blob: e4d9b04fa435bdc112b3a3d9c3da8a159cd3564c [file] [log] [blame]
Brad Bishop7cce0f22017-01-17 09:21:15 -05001SUMMARY = "Phosphor IPMI plugin for OpenPOWER OEM Commands"
2DESCRIPTION = "Phosphor IPMI plugin for OpenPOWER OEM Commands"
Chris Austen9d3325a2015-10-24 19:34:11 -05003PR = "r1"
Patrick Venture471c3582018-10-02 19:54:00 -07004PV = "1.0+git${SRCPV}"
Patrick Venture654ed6f2018-11-03 09:01:23 -07005LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
Chris Austen9d3325a2015-10-24 19:34:11 -05007
Matthew Barthe6d12952016-09-28 09:51:58 -05008inherit autotools pkgconfig
Tom Josephdcdc8ea2017-02-01 19:47:27 +05309inherit obmc-phosphor-ipmiprovider-symlink
Tom Joseph464b90a2017-10-17 22:52:49 +053010inherit pythonnative
11
12require ${PN}.inc
Chris Austen9d3325a2015-10-24 19:34:11 -050013
Brad Bishopceb1c9a2017-01-17 10:07:14 -050014DEPENDS += "phosphor-ipmi-host"
Matthew Barthe6d12952016-09-28 09:51:58 -050015DEPENDS += "autoconf-archive-native"
Patrick Williams04f099a2017-08-17 10:42:32 -050016DEPENDS += "sdbusplus sdbusplus-native"
17DEPENDS += "phosphor-logging"
18DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
19DEPENDS += "openpower-dbus-interfaces openpower-dbus-interfaces-native"
Tom Joseph464b90a2017-10-17 22:52:49 +053020DEPENDS += "sdbus++-native"
Tom Joseph087f5182019-01-28 21:41:27 -060021DEPENDS += "virtual/phosphor-ipmi-inventory-sel"
Patrick Williams04f099a2017-08-17 10:42:32 -050022
23RDEPENDS_${PN} += " \
24 sdbusplus \
25 phosphor-logging \
26 openpower-dbus-interfaces \
27 phosphor-dbus-interfaces \
28 "
Matthew Barthe6d12952016-09-28 09:51:58 -050029
Chris Austenf6d294d2016-01-23 18:00:11 -060030TARGET_CFLAGS += "-fpic"
Chris Austen9d3325a2015-10-24 19:34:11 -050031
Tom Josephdcdc8ea2017-02-01 19:47:27 +053032HOSTIPMI_PROVIDER_LIBRARY += "liboemhandler.so"
33
Tom Joseph087f5182019-01-28 21:41:27 -060034EXTRA_OECONF = " \
35 INVSENSOR_YAML_GEN=${STAGING_DIR_NATIVE}${datadir}/phosphor-ipmi-host/sensor/invsensor.yaml \
36 "
37
Chris Austen9d3325a2015-10-24 19:34:11 -050038S = "${WORKDIR}/git"
39
Tom Josephdcdc8ea2017-02-01 19:47:27 +053040FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
Matthew Barthe6d12952016-09-28 09:51:58 -050041FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
Tom Josephdcdc8ea2017-02-01 19:47:27 +053042FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"