Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Enables PPP dial-in through a serial connection" |
| 2 | SECTION = "console/network" |
| 3 | DEPENDS = "ppp" |
| 4 | RDEPENDS_${PN} = "ppp" |
| 5 | PR = "r8" |
| 6 | LICENSE = "MIT" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 7 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 8 | |
| 9 | SRC_URI = "file://host-peer \ |
| 10 | file://ppp-dialin" |
| 11 | |
| 12 | inherit allarch useradd |
| 13 | |
| 14 | S = "${WORKDIR}" |
| 15 | |
| 16 | do_install() { |
| 17 | install -d ${D}${sysconfdir}/ppp/peers |
| 18 | install -m 0644 ${WORKDIR}/host-peer ${D}${sysconfdir}/ppp/peers/host |
| 19 | |
| 20 | install -d ${D}${sbindir} |
| 21 | install -m 0755 ${WORKDIR}/ppp-dialin ${D}${sbindir} |
| 22 | } |
| 23 | |
| 24 | USERADD_PACKAGES = "${PN}" |
| 25 | USERADD_PARAM_${PN} = "--system --home /dev/null \ |
| 26 | --no-create-home --shell ${sbindir}/ppp-dialin \ |
| 27 | --no-user-group --gid nogroup ppp" |