blob: c13d6261c1befaf6afefd208f8975f056b52f961 [file] [log] [blame]
Patrick Williamsddad1a12017-02-23 20:36:32 -06001DESCRIPTION = "jackdmp is a C++ version of the JACK low-latency audio \
2server for multi-processor machines. It is a new implementation of the \
3JACK server core features that aims in removing some limitations of \
4the JACK1 design. The activation system has been changed for a data \
5flow model and lock-free programming techniques for graph access have \
6been used to have a more dynamic and robust system."
7SECTION = "libs/multimedia"
8
9LICENSE = "GPLv2 & LGPLv2.1"
10LIC_FILES_CHKSUM = " \
11 file://common/jack/control.h;beginline=2;endline=21;md5=e6df0bf30cde8b3b825451459488195d \
12 file://common/jack/jack.h;beginline=1;endline=19;md5=6b736ed6b810592b135480a5e853392e \
13"
14
Brad Bishop6e60e8b2018-02-01 10:27:11 -050015DEPENDS = "libsamplerate0 libsndfile1 readline"
Patrick Williamsddad1a12017-02-23 20:36:32 -060016
Brad Bishop0e2770c2020-01-21 07:31:46 -050017SRC_URI = "git://github.com/jackaudio/jack2.git \
18 file://0001-example-clients-Use-c-compiler-for-jack_simdtests.patch \
Andrew Geissler4b7c1152020-11-30 19:55:29 -060019 file://0001-Use-SYS_futex-instead-of-__NR_futex.patch \
Brad Bishop0e2770c2020-01-21 07:31:46 -050020 "
Andrew Geissler4b7c1152020-11-30 19:55:29 -060021SRCREV = "5b78c2ef158c2d9ffe09818a7dd80209ed251c5f"
Brad Bishop996bc452019-12-02 13:05:15 -050022
Patrick Williamsddad1a12017-02-23 20:36:32 -060023S = "${WORKDIR}/git"
24
25inherit waf pkgconfig
26
27PACKAGECONFIG ??= "alsa"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050028PACKAGECONFIG[alsa] = "--alsa=yes,--alsa=no,alsa-lib"
Brad Bishop19323692019-04-05 15:28:33 -040029# --dbus only stops building jackd -> add --classic
30PACKAGECONFIG[dbus] = "--dbus --classic,,dbus"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050031PACKAGECONFIG[opus] = "--opus=yes,--opus=no,libopus"
Patrick Williamsddad1a12017-02-23 20:36:32 -060032
33# portaudio is for windows builds only
34EXTRA_OECONF = "--portaudio=no"
35
Brad Bishop996bc452019-12-02 13:05:15 -050036do_install_append() {
37 if ! ${@bb.utils.contains('PACKAGECONFIG', 'dbus', True, False, d)}; then
38 rm -f ${D}${bindir}/jack_control
39 fi
40}
41
Patrick Williamsddad1a12017-02-23 20:36:32 -060042PACKAGES =+ "libjack jack-server jack-utils"
43
Brad Bishop6e60e8b2018-02-01 10:27:11 -050044RDEPENDS_jack-dev_remove = "${PN} (= ${EXTENDPKGV})"
45
Patrick Williamsddad1a12017-02-23 20:36:32 -060046FILES_libjack = "${libdir}/*.so.* ${libdir}/jack/*.so"
Brad Bishop19323692019-04-05 15:28:33 -040047FILES_jack-server = " \
48 ${datadir}/dbus-1/services \
49 ${bindir}/jackdbus \
50 ${bindir}/jackd \
51"
Patrick Williamsddad1a12017-02-23 20:36:32 -060052FILES_jack-utils = "${bindir}/*"
Brad Bishop19323692019-04-05 15:28:33 -040053
Brad Bishop996bc452019-12-02 13:05:15 -050054FILES_${PN}-doc += " ${datadir}/jack-audio-connection-kit/reference/html/*"