Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Very high-quality data compression program" |
| 2 | DESCRIPTION = "bzip2 compresses files using the Burrows-Wheeler block-sorting text compression algorithm, and \ |
| 3 | Huffman coding. Compression is generally considerably better than that achieved by more conventional \ |
| 4 | LZ77/LZ78-based compressors, and approaches the performance of the PPM family of statistical compressors." |
Brad Bishop | 220d553 | 2018-08-14 00:59:39 +0100 | [diff] [blame] | 5 | HOMEPAGE = "https://sourceware.org/bzip2/" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 6 | SECTION = "console/utils" |
| 7 | LICENSE = "bzip2" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame^] | 8 | LIC_FILES_CHKSUM = "file://LICENSE;beginline=4;endline=37;md5=39406315f540c69bd05b1531daedd2ae" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 9 | PR = "r5" |
| 10 | |
Brad Bishop | 220d553 | 2018-08-14 00:59:39 +0100 | [diff] [blame] | 11 | SRC_URI = "http://downloads.yoctoproject.org/mirror/sources/${BP}.tar.gz \ |
Patrick Williams | f1e5d69 | 2016-03-30 15:21:19 -0500 | [diff] [blame] | 12 | file://fix-bunzip2-qt-returns-0-for-corrupt-archives.patch \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 13 | file://configure.ac;subdir=${BP} \ |
| 14 | file://Makefile.am;subdir=${BP} \ |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 15 | file://run-ptest \ |
| 16 | file://CVE-2016-3189.patch \ |
| 17 | " |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 18 | |
| 19 | SRC_URI[md5sum] = "00b516f4704d4a7cb50a1d97e6e8e15b" |
| 20 | SRC_URI[sha256sum] = "a2848f34fcd5d6cf47def00461fcb528a0484d8edef8208d6d2e2909dc61d9cd" |
| 21 | |
Brad Bishop | 220d553 | 2018-08-14 00:59:39 +0100 | [diff] [blame] | 22 | UPSTREAM_CHECK_URI = "https://www.sourceware.org/bzip2/" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame^] | 23 | UPSTREAM_VERSION_UNKNOWN = "1" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 24 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 25 | PACKAGES =+ "libbz2" |
| 26 | |
| 27 | CFLAGS_append = " -fPIC -fpic -Winline -fno-strength-reduce -D_FILE_OFFSET_BITS=64" |
| 28 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 29 | inherit autotools update-alternatives ptest relative_symlinks |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 30 | |
| 31 | ALTERNATIVE_PRIORITY = "100" |
| 32 | ALTERNATIVE_${PN} = "bunzip2 bzcat" |
| 33 | |
| 34 | #install binaries to bzip2-native under sysroot for replacement-native |
| 35 | EXTRA_OECONF_append_class-native = " --bindir=${STAGING_BINDIR_NATIVE}/${PN}" |
| 36 | |
| 37 | do_install_ptest () { |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 38 | sed -i -e "s|^Makefile:|_Makefile:|" ${D}${PTEST_PATH}/Makefile |
| 39 | } |
| 40 | |
| 41 | FILES_libbz2 = "${libdir}/lib*${SOLIBS}" |
| 42 | |
| 43 | PROVIDES_append_class-native = " bzip2-replacement-native" |
| 44 | BBCLASSEXTEND = "native nativesdk" |
| 45 | |