Brad Bishop | 6a62e0e | 2019-10-21 08:11:42 -0400 | [diff] [blame] | 1 | SUMMARY = "fifo maps for c++" |
| 2 | HOMEPAGE = "https://github.com/nlohmann/fifo_map" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.MIT;md5=b67209a1e36b682a8226de19d265b1e0" |
| 6 | |
| 7 | SRC_URI = "git://github.com/nlohmann/fifo_map.git" |
| 8 | |
| 9 | PV = "1.0.0+git${SRCPV}" |
| 10 | |
| 11 | SRCREV = "0dfbf5dacbb15a32c43f912a7e66a54aae39d0f9" |
| 12 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 13 | UPSTREAM_CHECK_COMMITS = "1" |
| 14 | |
Brad Bishop | 6a62e0e | 2019-10-21 08:11:42 -0400 | [diff] [blame] | 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | # nlohmann-fifo is a header only C++ library, so the main package will be empty. |
| 18 | |
| 19 | RDEPENDS_${PN}-dev = "" |
| 20 | |
| 21 | BBCLASSEXTEND = "native nativesdk" |
| 22 | |
| 23 | do_install() { |
| 24 | install -d ${D}${includedir} |
| 25 | install -m 0644 ${S}/src/fifo_map.hpp ${D}${includedir} |
| 26 | } |