Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Interactive Connectivity Establishment library" |
| 2 | DESCRIPTION = "Libnice is an implementation of the IETF's draft Interactive Connectivity Establishment standard (ICE)." |
| 3 | HOMEPAGE = "http://nice.freedesktop.org/wiki/" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 4 | |
| 5 | LICENSE = "LGPLv2.1 & MPLv1.1" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=9c42325015702feda4f4d2f19a55b767 \ |
| 7 | file://COPYING.LGPL;md5=2d5025d4aa3495befef8f17206a5b0a1 \ |
| 8 | file://COPYING.MPL;md5=3c617710e51cdbe0fc00716f056dfb1a \ |
| 9 | " |
| 10 | |
Brad Bishop | 7e36d53 | 2019-09-16 07:44:26 -0400 | [diff] [blame] | 11 | SRC_URI = "http://nice.freedesktop.org/releases/libnice-${PV}.tar.gz" |
| 12 | SRC_URI[md5sum] = "5ad936c43d3c6d33117b2c64982f2fd9" |
| 13 | SRC_URI[sha256sum] = "06b678066f94dde595a4291588ed27acd085ee73775b8c4e8399e28c01eeefdf" |
| 14 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 15 | DEPENDS = "glib-2.0 gnutls" |
| 16 | |
| 17 | PACKAGECONFIG ??= "gstreamer1.0" |
| 18 | PACKAGECONFIG[gupnp] = "--enable-gupnp,--disable-gupnp,gupnp-igd" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 19 | PACKAGECONFIG[gstreamer1.0] = "--with-gstreamer,--without-gstreamer,gstreamer1.0 gstreamer1.0-plugins-base" |
| 20 | |
| 21 | inherit autotools pkgconfig gtk-doc gobject-introspection |
| 22 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 23 | EXTRA_OECONF += "--without-gstreamer-0.10" |
| 24 | |
| 25 | FILES_${PN} += "${libdir}/gstreamer-1.0/*.so" |
| 26 | FILES_${PN}-dev += "${libdir}/gstreamer-1.0/*.la" |
| 27 | FILES_${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a" |
| 28 | FILES_${PN}-dbg += "${libdir}/gstreamer-1.0/.debug" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 29 | |
| 30 | do_configure_prepend() { |
| 31 | mkdir ${S}/m4 || true |
| 32 | } |
| 33 | |
| 34 | do_compile_append() { |
| 35 | for i in $(find ${B} -name "*.pc") ; do |
| 36 | sed -i -e s:${STAGING_DIR_TARGET}::g \ |
| 37 | -e s:/${TARGET_SYS}::g \ |
| 38 | $i |
| 39 | done |
| 40 | } |