Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | PACKAGECONFIG_GL_rpi = "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'gl', \ |
Andrew Geissler | 1c34914 | 2019-02-19 19:49:56 -0600 | [diff] [blame] | 2 | bb.utils.contains('DISTRO_FEATURES', 'opengl', 'eglfs gles2', \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 3 | '', d), d)}" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 4 | PACKAGECONFIG_GL_append_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', ' kms', '', d)}" |
| 5 | PACKAGECONFIG_GL_append_rpi = " gbm" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 6 | PACKAGECONFIG_FONTS_rpi = "fontconfig" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 7 | PACKAGECONFIG_append_rpi = " libinput examples tslib xkb xkbcommon" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 8 | PACKAGECONFIG_remove_rpi = "tests" |
| 9 | |
Andrew Geissler | 1c34914 | 2019-02-19 19:49:56 -0600 | [diff] [blame] | 10 | OE_QTBASE_EGLFS_DEVICE_INTEGRATION_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', 'eglfs_brcm', d)}" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 11 | |
| 12 | do_configure_prepend_rpi() { |
| 13 | # Add the appropriate EGLFS_DEVICE_INTEGRATION |
| 14 | if [ "${@d.getVar('OE_QTBASE_EGLFS_DEVICE_INTEGRATION')}" != "" ]; then |
Andrew Geissler | 1c34914 | 2019-02-19 19:49:56 -0600 | [diff] [blame] | 15 | echo "EGLFS_DEVICE_INTEGRATION = ${OE_QTBASE_EGLFS_DEVICE_INTEGRATION}" >> ${S}/mkspecs/oe-device-extra.pri |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 16 | fi |
| 17 | } |
| 18 | RDEPENDS_${PN}_append_rpi = " userland" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 19 | DEPENDS_append_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', ' userland', d)}" |