Tim Lee | 1c9c10a | 2022-07-05 17:14:18 +0800 | [diff] [blame] | 1 | SUMMARY = "Image Generation and Programming Scripts for NPCM8XX (Arbel) devices" |
| 2 | DESCRIPTION = "Image Generation and Programming Scripts for NPCM8XX (Arbel) devices" |
| 3 | HOMEPAGE = "https://github.com/Nuvoton-Israel/igps-npcm8xx" |
| 4 | LICENSE = "GPLv2" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 6 | |
| 7 | SRC_URI = " \ |
| 8 | git://github.com/Nuvoton-Israel/igps-npcm8xx;branch=main;protocol=https \ |
| 9 | file://0001-Adjust-paths-for-use-with-Bitbake.patch \ |
| 10 | " |
| 11 | |
Tim Lee | 09508aa | 2022-09-13 15:40:47 +0800 | [diff] [blame] | 12 | # tag IGPS_03.06.04 |
| 13 | SRCREV = "6b056bb97a8f0e677d196afb6704372cae8bdd5b" |
Tim Lee | 1c9c10a | 2022-07-05 17:14:18 +0800 | [diff] [blame] | 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | DEST = "${D}${datadir}/${BPN}" |
| 18 | |
Tim Lee | 1c9c10a | 2022-07-05 17:14:18 +0800 | [diff] [blame] | 19 | do_install() { |
| 20 | install -d ${DEST} |
| 21 | install py_scripts/ImageGeneration/references/BootBlockAndHeader_${DEVICE_GEN}_${IGPS_MACHINE}.xml ${DEST} |
| 22 | install py_scripts/ImageGeneration/references/UbootHeader_${DEVICE_GEN}.xml ${DEST} |
| 23 | install py_scripts/ImageGeneration/inputs/BL31_AndHeader.xml ${DEST} |
| 24 | install py_scripts/ImageGeneration/inputs/OpTeeAndHeader.xml ${DEST} |
| 25 | } |
| 26 | |
| 27 | inherit native |